summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-04-10 09:11:21 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-05-15 19:07:10 -0700
commit59675662f0672ea205971e2c5626722dbef5305c (patch)
tree61a193bc48f7052a31353c6bc94f65efdaa6a473 /dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild
parentdev-python/sphinxcontrib-blockdiag: Add python-3.5, 3.6 to PYTHON_COMPAT (diff)
downloadgentoo-59675662f0672ea205971e2c5626722dbef5305c.tar.gz
gentoo-59675662f0672ea205971e2c5626722dbef5305c.tar.bz2
gentoo-59675662f0672ea205971e2c5626722dbef5305c.zip
dev-python/wsaccel: Version bump, Adds python-3.5, 3.6 support and tests
Create git commit release to include recent changes for newer python support. Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild')
-rw-r--r--dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild b/dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild
new file mode 100644
index 000000000000..97d3e9b5b778
--- /dev/null
+++ b/dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+COMMIT="0fbd074c257c51b73de05b25ccb6488801320a32"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accelerator for ws4py, autobahn and tornado"
+HOMEPAGE="https://pypi.python.org/pypi/wsaccel https://github.com/methane/wsaccel"
+SRC_URI="https://github.com/methane/wsaccel/archive/${COMMIT}.zip -> ${P}.zip"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_test() {
+ py.test -v || die
+}