summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-18 12:51:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-18 12:57:04 +0200
commitb9f51ebbf088d7045e745b7abf0c5058691d9523 (patch)
treed6396721e1f08374773aaa898a0ee939d503cc70 /dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild
parentdev-python/http-parser: Bump to 0.9.0 (diff)
downloadgentoo-b9f51ebbf088d7045e745b7abf0c5058691d9523.tar.gz
gentoo-b9f51ebbf088d7045e745b7abf0c5058691d9523.tar.bz2
gentoo-b9f51ebbf088d7045e745b7abf0c5058691d9523.zip
dev-python/wsgiproxy2: Remove dev-python/restkit dep
Upstream has removed restkit support entirely. The docs seem to still list it as a dep but ChangeLog disagrees, and there's no reference in sources. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild')
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..3b09cb27e9a5
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc64 s390 sparc x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ dev-python/socketpool[${PYTHON_USEDEP}]
+ )"
+# Testing also revealed the suite needs latest webtest
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/wsgiproxy2-0.4.6-tests.patch"
+)
+
+distutils_enable_sphinx docs
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -i '/with-coverage/ d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}