summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 15:08:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 15:29:58 +0200
commit3ee6d71f751ee969159a198fc809aa07492b6fca (patch)
tree447ce1c033c43cfdbe3040ffaf2d63ba98027010 /dev-python/wstools
parentapp-editors/nano: Removed old (diff)
downloadgentoo-3ee6d71f751ee969159a198fc809aa07492b6fca.tar.gz
gentoo-3ee6d71f751ee969159a198fc809aa07492b6fca.tar.bz2
gentoo-3ee6d71f751ee969159a198fc809aa07492b6fca.zip
dev-python/wstools: Bump to 0.4.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wstools')
-rw-r--r--dev-python/wstools/Manifest1
-rw-r--r--dev-python/wstools/wstools-0.4.10.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/wstools/Manifest b/dev-python/wstools/Manifest
index 91d4a8f4ec1e..239bd2c12efe 100644
--- a/dev-python/wstools/Manifest
+++ b/dev-python/wstools/Manifest
@@ -1 +1,2 @@
+DIST wstools-0.4.10.gh.tar.gz 204095 BLAKE2B 8d7652729846e991d84bf3c2b64394bf3954ae69cb1ed49ea7822432b965e5cfabd02f8d4ba7caa0cbf9df57def062b085aae75c5d4af1f9be078e2fd8031e0d SHA512 1acd8e62d71c7d330f1e953a0da1956291c5dfb25ff9b8b8799c83feaa4230e384955735b131bab7b430b92ae6c18498927d416d2d1e11fb5c5dad93417c671a
DIST wstools-0.4.8.tar.gz 199688 BLAKE2B 3b5137dd135ec8f0e6d69f94275d45367e609adb9763624fcabb899f84c6215c2df26485dcf32d44d6683bd97cd00e2d283cf9096b6f58414f2eacd9e8b93a4a SHA512 0f86e91a2de7333aaf5a58558a715edd6a0cf97150f6d0cae4ecf8e0702648a98e610aa6d3295444079bd616656efcb2823ae7c02c5c3ffcb4789548ac40cd0a
diff --git a/dev-python/wstools/wstools-0.4.10.ebuild b/dev-python/wstools/wstools-0.4.10.ebuild
new file mode 100644
index 000000000000..ae43a5fb3904
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="
+ https://github.com/pycontribs/wstools/
+ https://pypi.org/project/wstools/
+"
+SRC_URI="
+ https://github.com/pycontribs/wstools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-3.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/wstools-0.4.8-fix-py3.10.patch"
+)
+
+src_prepare() {
+ # remove the dep on pytest-runner
+ sed -i -e '/setup_requires/d' setup.py || die
+ # disabling xdist breaks random plugins
+ sed -i -e 's@-p no:xdist@@' pytest.ini || die
+ distutils-r1_src_prepare
+ export PBR_VERSION=${PV}
+}