summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-01 19:54:04 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-01 20:04:30 +0100
commit46a59dee7dfa37f123fa85f3333a593ca6bb0465 (patch)
tree1b2f40f2027a128e2e4224da8a6471890654273b /dev-python/wtf-peewee
parentdev-python/eventlet: Bump (diff)
downloadgentoo-46a59dee7dfa37f123fa85f3333a593ca6bb0465.tar.gz
gentoo-46a59dee7dfa37f123fa85f3333a593ca6bb0465.tar.bz2
gentoo-46a59dee7dfa37f123fa85f3333a593ca6bb0465.zip
dev-python/wtf-peewee: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/wtf-peewee')
-rw-r--r--dev-python/wtf-peewee/Manifest1
-rw-r--r--dev-python/wtf-peewee/wtf-peewee-0.2.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/wtf-peewee/Manifest b/dev-python/wtf-peewee/Manifest
index 2291282d74fc..0e140a3ca737 100644
--- a/dev-python/wtf-peewee/Manifest
+++ b/dev-python/wtf-peewee/Manifest
@@ -1 +1,2 @@
DIST wtf-peewee-0.2.3.tar.gz 60654 SHA256 d64bab9c8b9b247f21534e87a94b988afd9655d7abaa14dc7d2af0bea3a3b9da SHA512 0a8e4a6586a4521d99c35b907935286c20b9106214a9826960073e710fc0a91c68402b9812d2b0119263786f8e48bdcacf999044ade9f3a27afa9bc7fd058926 WHIRLPOOL b44d3480d274f26ff84993c8941c473e6104bab8cd65bd8befb903dc9f2d6fad16299d6b4fc5f3b8af822dbc6aa9781dbe9ba43da6fb2f2dcf929578d3eac7ea
+DIST wtf-peewee-0.2.4.tar.gz 60869 SHA256 e771daf99ec6ecab0771742f3bb104058cd5e0b72ad404c6d278b6eefc116349 SHA512 f63ecae4b39873124d11408a58732cc147a7b8a68b7f19be1f8ff67c4847b7daddd9f62c180a723af00176d2d13531fa30d076cf64ea618c260da522555ec7e7 WHIRLPOOL 0fcbc0c919e1df3af1f5d2787ebb8934c697e7dc6f65c9b264306d62a9b552e8969658c7cf6654f260b0e902b4aa3708aed694b36b4262cbf4e3e49aa2c9e43e
diff --git a/dev-python/wtf-peewee/wtf-peewee-0.2.4.ebuild b/dev-python/wtf-peewee/wtf-peewee-0.2.4.ebuild
new file mode 100644
index 000000000000..ad5ad9d976da
--- /dev/null
+++ b/dev-python/wtf-peewee/wtf-peewee-0.2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test"
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-python/peewee-2.0.0[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( "${RDEPEND}" )"
+
+python_prepare_all() {
+ # https://github.com/coleifer/peewee/issues/361
+ sed -e s':test_null_form_saving:_&:' -i "${PN/\-/}"/tests.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}