summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-22 08:55:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-22 09:25:23 +0200
commit2ffc2cd2d98342de43ecf03e0750ec41a331c9eb (patch)
treef2ef7036dba7e4e651ca12a62f1bc105d3b233e6 /dev-python/wurlitzer/wurlitzer-2.1.1.ebuild
parentdev-python/requests-cache: Bump to 0.7.2 (diff)
downloadgentoo-2ffc2cd2d98342de43ecf03e0750ec41a331c9eb.tar.gz
gentoo-2ffc2cd2d98342de43ecf03e0750ec41a331c9eb.tar.bz2
gentoo-2ffc2cd2d98342de43ecf03e0750ec41a331c9eb.zip
dev-python/wurlitzer: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wurlitzer/wurlitzer-2.1.1.ebuild')
-rw-r--r--dev-python/wurlitzer/wurlitzer-2.1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/wurlitzer/wurlitzer-2.1.1.ebuild b/dev-python/wurlitzer/wurlitzer-2.1.1.ebuild
new file mode 100644
index 000000000000..7a64cf34ebad
--- /dev/null
+++ b/dev-python/wurlitzer/wurlitzer-2.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Capture C-level stdout/stderr in Python"
+HOMEPAGE="
+ https://github.com/minrk/wurlitzer/
+ https://pypi.org/project/wurlitzer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}