summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-30 09:05:40 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-30 09:25:31 +0100
commit056e8649ceb45c671b26bcc82bc83f31f375b09b (patch)
tree912256f9870c89235e5259df1f2e8414dadc146e /dev-python/xcffib/xcffib-0.11.1.ebuild
parentdev-python/PyGithub: Bump to 1.54 (diff)
downloadgentoo-056e8649ceb45c671b26bcc82bc83f31f375b09b.tar.gz
gentoo-056e8649ceb45c671b26bcc82bc83f31f375b09b.tar.bz2
gentoo-056e8649ceb45c671b26bcc82bc83f31f375b09b.zip
dev-python/xcffib: Bump to 0.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xcffib/xcffib-0.11.1.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-0.11.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/xcffib/xcffib-0.11.1.ebuild b/dev-python/xcffib/xcffib-0.11.1.ebuild
new file mode 100644
index 000000000000..790a52834b15
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.11.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+distutils_enable_tests nose