summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-17 16:28:31 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-18 00:44:23 -0400
commitbf4cfb8836dc9485dfc12852a370c6b1f4d03d5b (patch)
tree11de61374c616562cc62011ac697822595d9b0ed /dev-python/xcffib/xcffib-0.6.0.ebuild
parentmedia-libs/exiftool: version bump to 10.86 (diff)
downloadgentoo-bf4cfb8836dc9485dfc12852a370c6b1f4d03d5b.tar.gz
gentoo-bf4cfb8836dc9485dfc12852a370c6b1f4d03d5b.tar.bz2
gentoo-bf4cfb8836dc9485dfc12852a370c6b1f4d03d5b.zip
dev-python/xcffib: version bump to 0.6.0
Diffstat (limited to 'dev-python/xcffib/xcffib-0.6.0.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-0.6.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/xcffib/xcffib-0.6.0.ebuild b/dev-python/xcffib/xcffib-0.6.0.ebuild
new file mode 100644
index 000000000000..e71079b5ba85
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ dev-python/six[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
+
+python_test() {
+ nosetests -d -v || die
+}