summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-06-22 14:56:06 -0600
committerTim Harder <radhermit@gentoo.org>2019-06-22 14:56:06 -0600
commit5ea466de43727e23ed68a338cf6b794a23b2c4ba (patch)
tree1261e41e0bd4c3f6b5a63c8d8bba44ebe45da392 /dev-python/xcffib/xcffib-0.8.1.ebuild
parentmedia-libs/exiftool: version bump to 11.52 (diff)
downloadgentoo-5ea466de43727e23ed68a338cf6b794a23b2c4ba.tar.gz
gentoo-5ea466de43727e23ed68a338cf6b794a23b2c4ba.tar.bz2
gentoo-5ea466de43727e23ed68a338cf6b794a23b2c4ba.zip
dev-python/xcffib: version bump to 0.8.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/xcffib/xcffib-0.8.1.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-0.8.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xcffib/xcffib-0.8.1.ebuild b/dev-python/xcffib/xcffib-0.8.1.ebuild
new file mode 100644
index 000000000000..528b8913b976
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ dev-python/six[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
+
+python_test() {
+ virtx nosetests -d -v || die
+}