summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-26 12:48:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-26 13:05:39 +0200
commit5f8bc31b3ae132fc99dcffb222439bf80db9dba0 (patch)
tree70f1e7130d7ed6628895a4e3a2459455a291d86e /dev-python/xcffib
parentdev-python/h11: Bump to 0.14.0 (diff)
downloadgentoo-5f8bc31b3ae132fc99dcffb222439bf80db9dba0.tar.gz
gentoo-5f8bc31b3ae132fc99dcffb222439bf80db9dba0.tar.bz2
gentoo-5f8bc31b3ae132fc99dcffb222439bf80db9dba0.zip
dev-python/xcffib: Bump to 0.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xcffib')
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-0.12.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 270ed80f043b..ad47711adbfa 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1 +1,2 @@
DIST xcffib-0.11.1.tar.gz 84713 BLAKE2B 6ab1ad6e582d71214cd719fdfa898e561e29d5750f5befe5c71173cfe34f2dff7dbd52fe93e618aab695646850f7ef5420114e2b1e725150c643904cdaba560a SHA512 09f4e19b88258446af26628c3a8e694c1f938fe3b5456e797b06174602fa0e9ef6e4eab76daccfd169d98fb7e869c910e6216d1f71fa2853e62b82c62c667669
+DIST xcffib-0.12.1.tar.gz 85272 BLAKE2B 6db2f19caf13d406297198c3829456cb45b5195e2d068b1f5ad01c25d4ed75e3187854da24156c3c5396a559b11c2d6949711b793c5bf5c83e18e9aa54307983 SHA512 6530fb53fa18a3905d7c9e8dd5d05ea084de4a5f392e32953a9786998dd194b2db55b54fa44dbc3e6b68e68ae00431de7432d6884f777734409d660dae325d6e
diff --git a/dev-python/xcffib/xcffib-0.12.1.ebuild b/dev-python/xcffib/xcffib-0.12.1.ebuild
new file mode 100644
index 000000000000..e4702f7739ee
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="
+ https://github.com/tych0/xcffib/
+ https://pypi.org/project/xcffib/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ x11-libs/libxcb
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )
+"
+
+distutils_enable_tests pytest