summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 15:31:54 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 15:31:57 +0200
commitd1bf7bfe141a24fc7154ee92578ec935c5cccefd (patch)
tree7b880f2ced335da13837b88ea108a51e048ccbdf /dev-python/xcffib
parentdev-python/numexpr: pep517, enable py3.11 (diff)
downloadgentoo-d1bf7bfe141a24fc7154ee92578ec935c5cccefd.tar.gz
gentoo-d1bf7bfe141a24fc7154ee92578ec935c5cccefd.tar.bz2
gentoo-d1bf7bfe141a24fc7154ee92578ec935c5cccefd.zip
dev-python/xcffib: update EAPI 7 -> 8, enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/xcffib')
-rw-r--r--dev-python/xcffib/xcffib-0.11.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/xcffib/xcffib-0.11.1-r1.ebuild b/dev-python/xcffib/xcffib-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..1be25014aed3
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.11.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+distutils_enable_tests pytest