summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-28 11:39:56 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-28 12:07:09 -0700
commit8835ca6b42ef36b0c068bd70001c108f0522d615 (patch)
treebb890a00f9a773e60b299875368e86b6ec5d0138 /dev-python/xdis/xdis-3.3.0.ebuild
parentdev-python/xdis: Version bump, remove older versions not compatible with pyth... (diff)
downloadgentoo-8835ca6b42ef36b0c068bd70001c108f0522d615.tar.gz
gentoo-8835ca6b42ef36b0c068bd70001c108f0522d615.tar.bz2
gentoo-8835ca6b42ef36b0c068bd70001c108f0522d615.zip
dev-python/xdis: Version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-python/xdis/xdis-3.3.0.ebuild')
-rw-r--r--dev-python/xdis/xdis-3.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/xdis/xdis-3.3.0.ebuild b/dev-python/xdis/xdis-3.3.0.ebuild
new file mode 100644
index 000000000000..9885cf155d48
--- /dev/null
+++ b/dev-python/xdis/xdis-3.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Python cross-version byte-code disassembler and marshal routines"
+HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.python.org/pypi/xdis"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/xdis-test_magic_bytes_error.patch"
+ "${FILESDIR}/xdis-3.3.0-remove-pytest-runner-dep.patch"
+)
+
+python_test() {
+ # Need to rm any pyc files to prevent test failures.
+ rm -R "${S}"/test/__pycache__
+ PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \
+ py.test -v || die "Tests failed under ${EPYTHON}"
+ cd test
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ ${EPYTHON} test_pyenvlib.py --verify --simple --compile || die \
+ "Tests failed under ${EPYTHON}"
+}