summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-11 08:29:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-11 09:06:08 +0200
commitb457bfb8f556dc87c17e8c71d5a59eabddbcb824 (patch)
tree33953ff2ea079248ccbcffc91cf2be789699b746 /dev-python/xdoctest
parentdev-python/hatchling: Bump to 1.5.0 (diff)
downloadgentoo-b457bfb8f556dc87c17e8c71d5a59eabddbcb824.tar.gz
gentoo-b457bfb8f556dc87c17e8c71d5a59eabddbcb824.tar.bz2
gentoo-b457bfb8f556dc87c17e8c71d5a59eabddbcb824.zip
dev-python/xdoctest: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.0.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 763c097d4ac4..15fcae8bf6f0 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-1.0.0.gh.tar.gz 193294 BLAKE2B 95725757faafd2a15652557e07753ad8c4a8ee57b545169ba29b6e8f0ef5c7a021eff3c092cfe123da91311db98ef7700b29d52b1418a8160869402fb4ecfcab SHA512 8c77fbd8fcd1a3030b33651d35567dd4506ece3aa2c6155223d5cdea6e16510b59bcbd5b9ebb6dc13e20af92c5d07dc205485566b836874e835b18a53cbe7355
+DIST xdoctest-1.0.1.gh.tar.gz 200921 BLAKE2B 29d4947e8a49b11721c2ab8500e12334c9937d892519154267ad1ff3f98e3a35767eb770ed40d34c253e282e09e90de2567b92fd7b3167f7d8a58dcd762bc43d SHA512 c853f0b673ebc8b1f6fc6305a8688bffdf33cabab734a53f4ed1668d4f94d0431dd6e867b30a1c4588a86f3552e9b94ceaf540c3ed8e66f80bd9ce45ddbae690
diff --git a/dev-python/xdoctest/xdoctest-1.0.1.ebuild b/dev-python/xdoctest/xdoctest-1.0.1.ebuild
new file mode 100644
index 000000000000..a1433e00c391
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest/"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx_rtd_theme
+
+python_test() {
+ epytest --pyargs tests xdoctest
+}