summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-08 10:01:51 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-08 10:01:51 -0400
commitf636a06361dc416be5ec0a921fc12be2a0652c8f (patch)
tree31030ea91d9e65d95369adb2e63fe23df8bce6cb /dev-python/xlrd/xlrd-1.2.0.ebuild
parentwww-client/opera: Version 60.0.3255.83 (diff)
downloadgentoo-f636a06361dc416be5ec0a921fc12be2a0652c8f.tar.gz
gentoo-f636a06361dc416be5ec0a921fc12be2a0652c8f.tar.bz2
gentoo-f636a06361dc416be5ec0a921fc12be2a0652c8f.zip
dev-python/xlrd: bump to 1.2.0
Closes: https://bugs.gentoo.org/639272 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/xlrd/xlrd-1.2.0.ebuild')
-rw-r--r--dev-python/xlrd/xlrd-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/xlrd/xlrd-1.2.0.ebuild b/dev-python/xlrd/xlrd-1.2.0.ebuild
new file mode 100644
index 000000000000..26f2f8ff4190
--- /dev/null
+++ b/dev-python/xlrd/xlrd-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to extract data from Microsoft Excel spreadsheets"
+HOMEPAGE="http://www.python-excel.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove this if examples get reintroduced
+ sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
+}