summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-14 11:28:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-14 12:15:09 +0100
commitf23aab6cb2666bd6346d168ee7e6080bc6694f61 (patch)
treea9771c03981c2ade7ae484c737ec2161e19e7d5c /dev-python/xmlschema/xmlschema-1.5.3.ebuild
parentapp-metrics/prometheus-bin: Old (diff)
downloadgentoo-f23aab6cb2666bd6346d168ee7e6080bc6694f61.tar.gz
gentoo-f23aab6cb2666bd6346d168ee7e6080bc6694f61.tar.bz2
gentoo-f23aab6cb2666bd6346d168ee7e6080bc6694f61.zip
dev-python/xmlschema: Bump to 1.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema/xmlschema-1.5.3.ebuild')
-rw-r--r--dev-python/xmlschema/xmlschema-1.5.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xmlschema/xmlschema-1.5.3.ebuild b/dev-python/xmlschema/xmlschema-1.5.3.ebuild
new file mode 100644
index 000000000000..bb3a6af5bf3d
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.1.2[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}