summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-30 13:03:39 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-30 13:03:49 +0100
commitab77ec100bc2bcefe46e79e700a392197bce0cfc (patch)
tree87238da4222664bb5f4617bd26a730d7e26bffad /dev-python/xmpppy/xmpppy-0.5.0_rc1-r2.ebuild
parentdev-python/twill: Move to virtual/dnspython (diff)
downloadgentoo-ab77ec100bc2bcefe46e79e700a392197bce0cfc.tar.gz
gentoo-ab77ec100bc2bcefe46e79e700a392197bce0cfc.tar.bz2
gentoo-ab77ec100bc2bcefe46e79e700a392197bce0cfc.zip
dev-python/xmpppy: Move to virtual/dnspython
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/xmpppy/xmpppy-0.5.0_rc1-r2.ebuild')
-rw-r--r--dev-python/xmpppy/xmpppy-0.5.0_rc1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xmpppy/xmpppy-0.5.0_rc1-r2.ebuild b/dev-python/xmpppy/xmpppy-0.5.0_rc1-r2.ebuild
new file mode 100644
index 000000000000..c9cc7fab7fdd
--- /dev/null
+++ b/dev-python/xmpppy/xmpppy-0.5.0_rc1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Python library providing easy scripting with Jabber"
+HOMEPAGE="http://xmpppy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xmpppy/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ || (
+ virtual/dnspython[${PYTHON_USEDEP}]
+ dev-python/pydns[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-hashlib_ssl_deprecation.patch"
+)
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}