summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-09-06 18:44:25 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-09-08 20:35:03 +0200
commit25a20900778ccf3347de2228f24fe3dee92e703c (patch)
tree3aea2b3c42ce580b82315d7bcc98ef69733f47a3 /dev-python/xxhash/xxhash-2.0.0.ebuild
parentnet-misc/s3cmd: amd64 stable (diff)
downloadgentoo-25a20900778ccf3347de2228f24fe3dee92e703c.tar.gz
gentoo-25a20900778ccf3347de2228f24fe3dee92e703c.tar.bz2
gentoo-25a20900778ccf3347de2228f24fe3dee92e703c.zip
dev-python/xxhash: new package
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.4, Repoman-3.0.1 Closes: https://github.com/gentoo/gentoo/pull/17442 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/xxhash/xxhash-2.0.0.ebuild')
-rw-r--r--dev-python/xxhash/xxhash-2.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xxhash/xxhash-2.0.0.ebuild b/dev-python/xxhash/xxhash-2.0.0.ebuild
new file mode 100644
index 000000000000..ea7b6e71a9a1
--- /dev/null
+++ b/dev-python/xxhash/xxhash-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..8})
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding for the xxHash library"
+HOMEPAGE="https://github.com/ifduyue/python-xxhash
+ https://pypi.org/project/xxhash/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-libs/xxhash-0.8.0"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ export XXHASH_LINK_SO=1
+}
+
+python_test() {
+ cd tests
+ "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
+}