summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 01:28:10 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:26 -0500
commit1c6294c94161a983b14a00cbd478986f94713fc3 (patch)
tree70056f5811424d83233d6dbbe3f5149224d3028f /dev-python/yappi/yappi-1.0.ebuild
parentdev-python/kombu: 4.4.0 bump (diff)
downloadgentoo-1c6294c94161a983b14a00cbd478986f94713fc3.tar.gz
gentoo-1c6294c94161a983b14a00cbd478986f94713fc3.tar.bz2
gentoo-1c6294c94161a983b14a00cbd478986f94713fc3.zip
dev-python/yappi: 1.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/yappi/yappi-1.0.ebuild')
-rw-r--r--dev-python/yappi/yappi-1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/yappi/yappi-1.0.ebuild b/dev-python/yappi/yappi-1.0.ebuild
new file mode 100644
index 000000000000..1c9e69e16698
--- /dev/null
+++ b/dev-python/yappi/yappi-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{4,5,6,7}})
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="https://bitbucket.org/sumerc/yappi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}