summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-15 00:58:27 +0100
committerSam James <sam@gentoo.org>2022-01-28 05:15:01 +0000
commit1bc23b7928c622b87d069fd58ca7f43686e83f29 (patch)
treea0f6675246ae5ee416cb1b615a4655638d6105ad /dev-python/yara-python
parentapp-forensics/yara: new ebuild (diff)
downloadgentoo-1bc23b7928c622b87d069fd58ca7f43686e83f29.tar.gz
gentoo-1bc23b7928c622b87d069fd58ca7f43686e83f29.tar.bz2
gentoo-1bc23b7928c622b87d069fd58ca7f43686e83f29.zip
dev-python/yara-python: new ebuild
Bug: https://bugs.gentoo.org/800275 Closes: https://bugs.gentoo.org/576956 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/23800 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/yara-python')
-rw-r--r--dev-python/yara-python/Manifest1
-rw-r--r--dev-python/yara-python/metadata.xml20
-rw-r--r--dev-python/yara-python/yara-python-4.1.3.ebuild27
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/yara-python/Manifest b/dev-python/yara-python/Manifest
new file mode 100644
index 000000000000..eaf58cf3e445
--- /dev/null
+++ b/dev-python/yara-python/Manifest
@@ -0,0 +1 @@
+DIST yara-python-4.1.3.tar.gz 33712 BLAKE2B 7878d12620f2834578c98a99bc259422d8ac54efc04ebd29ffa604c15b0462607ce950b3e19f8e80db07195e61dedb4efc8c2ffb18a0c5de0bf2755fe62776d1 SHA512 9c96ae78df7694dd55b8bdde4fad49043f120b94477fa9d7090610665072626eba4fa410cd9292205e0b18bb9f384f07288c0340232e163294b91051b84dcab2
diff --git a/dev-python/yara-python/metadata.xml b/dev-python/yara-python/metadata.xml
new file mode 100644
index 000000000000..05c387a64124
--- /dev/null
+++ b/dev-python/yara-python/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ With this library you can use YARA from your Python programs. It covers
+ all YARA's features, from compiling, saving and loading rules to
+ scanning files, strings and processes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">VirusTotal/yara-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/yara-python/yara-python-4.1.3.ebuild b/dev-python/yara-python/yara-python-4.1.3.ebuild
new file mode 100644
index 000000000000..54194680cc20
--- /dev/null
+++ b/dev-python/yara-python/yara-python-4.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ =app-forensics/yara-4.1*"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ compile_python() {
+ distutils-r1_python_compile --dynamic-linking
+ }
+ python_foreach_impl compile_python
+}