summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-10 22:08:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-10 22:21:12 +0200
commit941f280840e7c6776c10023ba5fa607ed80f436e (patch)
tree06b8d36a26fea48f58168f76472756671217b93f /dev-python/youtube-search-python
parentapp-emulation/virt-manager: tidy (diff)
downloadgentoo-941f280840e7c6776c10023ba5fa607ed80f436e.tar.gz
gentoo-941f280840e7c6776c10023ba5fa607ed80f436e.tar.bz2
gentoo-941f280840e7c6776c10023ba5fa607ed80f436e.zip
dev-python/youtube-search-python: bump to 1.6.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/youtube-search-python')
-rw-r--r--dev-python/youtube-search-python/Manifest1
-rw-r--r--dev-python/youtube-search-python/youtube-search-python-1.6.4.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/youtube-search-python/Manifest b/dev-python/youtube-search-python/Manifest
index 1a181d73d22b..a424aa29bb11 100644
--- a/dev-python/youtube-search-python/Manifest
+++ b/dev-python/youtube-search-python/Manifest
@@ -1 +1,2 @@
DIST youtube-search-python-1.6.3.tar.gz 115934 BLAKE2B 1151a29da0d66206424a88a2ac3839269f11d970b4a829f9d33ede4ef7ffec39c6762bfe138edd5da9c57308444021be93054c34cbc71e12a031a8d798d94975 SHA512 16d0dfbc95387bb3ccac9224e53ea087cdfa41d1330abd96fc3ad0136af227359fc2d8409a2eca81ae2fe9790efdb86a42e409748ba1a49c595df2629216e331
+DIST youtube-search-python-1.6.4.tar.gz 116117 BLAKE2B 297e171cf72381994ed93804833b49182c5099db8584937258867ec9f9e14c680a5cf4c9f09fe186e1d5405481afb6656dab35f204c09bcf2f77d07de9b4103a SHA512 50109d5704ceabe101b6190a157a656eb3690bc29b95112526fc1363935d14afc142af6c5bf512a38c3938f06db06a50a26f9a13d1601abd0fa224a0cd3b84f5
diff --git a/dev-python/youtube-search-python/youtube-search-python-1.6.4.ebuild b/dev-python/youtube-search-python/youtube-search-python-1.6.4.ebuild
new file mode 100644
index 000000000000..923cfa88f17f
--- /dev/null
+++ b/dev-python/youtube-search-python/youtube-search-python-1.6.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get YouTube video information using link WITHOUT YouTube Data API v3"
+HOMEPAGE="https://github.com/alexmercerind/youtube-search-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ net-misc/yt-dlp[${PYTHON_USEDEP}]
+"