summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/zake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/zake')
-rw-r--r--dev-python/zake/Manifest1
-rw-r--r--dev-python/zake/metadata.xml16
-rw-r--r--dev-python/zake/zake-0.2.1.ebuild30
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/zake/Manifest b/dev-python/zake/Manifest
new file mode 100644
index 000000000000..19bc446915e0
--- /dev/null
+++ b/dev-python/zake/Manifest
@@ -0,0 +1 @@
+DIST zake-0.2.1.tar.gz 12972 SHA256 2e5bcb215e366e682fd05dd1df4f2e6affceefa5d3781c2987a21fd597659a21 SHA512 a9f7ddeb202e16355680d8aeb39af920eeb4280352cf746c630d208567c948efe78036032d4a6ca7b1f719093eaeb1ffa071c66975bd8036a9015706d64a76d2 WHIRLPOOL 411ea1d8463b68633e3ee4717524c0b316476b060b3b3177016a4c8fe0f539361f920c516cf5f25592a46b40fd88978840fe820161314e4aa0744cc9f01fbe00
diff --git a/dev-python/zake/metadata.xml b/dev-python/zake/metadata.xml
new file mode 100644
index 000000000000..e02601cd5455
--- /dev/null
+++ b/dev-python/zake/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A python package that works to provide a nice set of testing utilities for the kazoo library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">zake</remote-id>
+ <remote-id type="github">yahoo/Zake</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zake/zake-0.2.1.ebuild b/dev-python/zake/zake-0.2.1.ebuild
new file mode 100644
index 000000000000..9a197203e6b8
--- /dev/null
+++ b/dev-python/zake/zake-0.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python package that works to provide a nice set of testing utilities for the kazoo library."
+HOMEPAGE=" https://github.com/yahoo/Zake"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/kazoo[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m nose || die
+}