summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2016-09-25 06:28:06 +0100
committerAlice Ferrazzi <alicef@gentoo.org>2016-09-25 06:39:26 +0100
commitdda48632627240c99c5438db7c62c98050ca604d (patch)
treee2f3e4e1ca21a17066ae5763fa07f799ed9e89a3 /dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
parentdev-python/fabric: version bump to 1.12.0 (diff)
downloadgentoo-dda48632627240c99c5438db7c62c98050ca604d.tar.gz
gentoo-dda48632627240c99c5438db7c62c98050ca604d.tar.bz2
gentoo-dda48632627240c99c5438db7c62c98050ca604d.zip
dev-python/zc-buildout: version bump to 2.5.3
updated copyright Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/zc-buildout/zc-buildout-2.5.3.ebuild')
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.5.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild b/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
new file mode 100644
index 000000000000..1341a17ca411
--- /dev/null
+++ b/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="System for managing development buildouts"
+HOMEPAGE="https://pypi.python.org/pypi/zc.buildout"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( README.rst doc/tutorial.txt )
+# Tests require zope packages absent from portage
+
+# Prevent incorrect installation of data file
+python_prepare_all() {
+ sed -e '/^ include_package_data/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}