summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-21 14:16:20 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-21 15:55:12 -0800
commitc0c0ba7575e436b0d9087a97a991b9c50f11ae19 (patch)
treedf26af13635466fd072da51f25f98b630e90aca3 /dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
parentdev-python/jaraco-envs: New package (diff)
downloadgentoo-c0c0ba7575e436b0d9087a97a991b9c50f11ae19.tar.gz
gentoo-c0c0ba7575e436b0d9087a97a991b9c50f11ae19.tar.bz2
gentoo-c0c0ba7575e436b0d9087a97a991b9c50f11ae19.zip
dev-python/zc-lockfile: Version bump to 2.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/zc-lockfile/zc-lockfile-2.0.ebuild')
-rw-r--r--dev-python/zc-lockfile/zc-lockfile-2.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild b/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
new file mode 100644
index 000000000000..66a97118c5c1
--- /dev/null
+++ b/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Basic inter-process locks"
+HOMEPAGE="https://pypi.org/project/zc.lockfile/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests nose
+
+# Prevent incorrect installation of data file
+python_prepare_all() {
+ sed -e '/^ include_package_data/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_moduleinto zc
+ python_domodule src/zc/__init__.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}