summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-22 13:57:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-22 14:01:00 +0200
commitbdf4ec2b952bef70e291424635379e8b23119a33 (patch)
treed3899150346123ccb831661974e4b579c31e2946 /dev-python/zc-lockfile
parentdev-python/ovs: Remove old (diff)
downloadgentoo-bdf4ec2b952bef70e291424635379e8b23119a33.tar.gz
gentoo-bdf4ec2b952bef70e291424635379e8b23119a33.tar.bz2
gentoo-bdf4ec2b952bef70e291424635379e8b23119a33.zip
dev-python/zc-lockfile: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zc-lockfile')
-rw-r--r--dev-python/zc-lockfile/zc-lockfile-2.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild b/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
deleted file mode 100644
index ba8a0dc845db..000000000000
--- a/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Basic inter-process locks"
-HOMEPAGE="https://pypi.org/project/zc.lockfile/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ~ppc64 ~riscv ~sparc x86"
-
-BDEPEND="test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
-
-DOCS=( CHANGES.rst README.rst )
-
-distutils_enable_tests nose
-
-# Prevent incorrect installation of data file
-python_prepare_all() {
- sed -e '/^ include_package_data/d' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install
-
- python_moduleinto zc
- python_domodule src/zc/__init__.py
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}