summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-15 02:58:58 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-15 04:22:37 +0200
commitb92b7b925e14a42a3fcae4856a70c711d978cbb6 (patch)
treebd20b524d94222fba4c6c2790f2591b7c3be70c5 /dev-python/zeep/zeep-4.0.0.ebuild
parentdev-python/aioresponses: new package, test dep. of zeep, v0.7.2 (diff)
downloadgentoo-b92b7b925e14a42a3fcae4856a70c711d978cbb6.tar.gz
gentoo-b92b7b925e14a42a3fcae4856a70c711d978cbb6.tar.bz2
gentoo-b92b7b925e14a42a3fcae4856a70c711d978cbb6.zip
dev-python/zeep: add 4.0.0, enable py3.10 and tests
Also stop overriding DOCS which only contains standard file names. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/zeep/zeep-4.0.0.ebuild')
-rw-r--r--dev-python/zeep/zeep-4.0.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/zeep/zeep-4.0.0.ebuild b/dev-python/zeep/zeep-4.0.0.ebuild
new file mode 100644
index 000000000000..5b9cebfc0b45
--- /dev/null
+++ b/dev-python/zeep/zeep-4.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
+HOMEPAGE="http://docs.python-zeep.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="async tornado"
+
+# TODO: remove six dependency when this is merged:
+# https://github.com/mvantellingen/python-zeep/pull/1250
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-file-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ async? ( >=dev-python/aiohttp-1.0[${PYTHON_USEDEP}] )
+ tornado? (
+ >=www-servers/tornado-4.0.2[${PYTHON_USEDEP}]
+ <www-servers/tornado-5[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/aioresponses[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/python-xmlsec[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest