summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:15:06 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:45:52 -0600
commit59683e5f1d33a7da20db2830f6251d575a91e161 (patch)
treeb0917e03196d0c7a9effae275b2552df4134d655 /dev-python/zeroconf
parentdev-python/ifaddr: add for new zeroconf version (diff)
downloadgentoo-59683e5f1d33a7da20db2830f6251d575a91e161.tar.gz
gentoo-59683e5f1d33a7da20db2830f6251d575a91e161.tar.bz2
gentoo-59683e5f1d33a7da20db2830f6251d575a91e161.zip
dev-python/zeroconf: 0.24.4 bump for py3 pulseaudio-dlna
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.24.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 2369e242e959..0873ccc4bd0a 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST zeroconf-0.19.1.tar.gz 22769 BLAKE2B a63332d70c5610da4fe44cc32d106893241284c3f70b5d6f55f68e3b3dd045a9c39b1009e9dce0b80c836d5ab0693b99974901ee664513c36f34c31907162d46 SHA512 1a7ac803caca1b230eba6c4bcfb714613f218850d9373ea0de609a3c9a509d13acfd14d64f9efbab78637b74aebdf385cf2deded1ff871fc6f3aea4477a07730
+DIST zeroconf-0.24.4.tar.gz 51866 BLAKE2B dd71bda4b0759c61a3e5895e766dff6516ea81ca0c8c9f5a95a8093de8a3a9b15722b99a6af0092b02c1b292bcdb11c02c9f165003b56ca8a793f4a4ca8fd891 SHA512 71678521b05016a7404005a06c8109f861cc8bfe2b3375ac6f1da8f63771271a3d9a095a8db6ccea2e062c5cc28b750a50fbe69218de72646b13a5f03359ea17
diff --git a/dev-python/zeroconf/zeroconf-0.24.4.ebuild b/dev-python/zeroconf/zeroconf-0.24.4.ebuild
new file mode 100644
index 000000000000..8764e749eec3
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.24.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="https://github.com/jstasiak/python-zeroconf https://pypi.org/project/zeroconf/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/ifaddr[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# Not included
+RESTRICT="test"
+
+python_prepare_all() {
+ # It's virtual/python-enum34
+ sed \
+ -e "s:'enum-compat',::g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbose || die
+}