summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-07-13 03:38:04 +0200
committerLouis Sautier <sbraz@gentoo.org>2019-07-13 03:38:04 +0200
commitb1a3d3c12b3e8537665ddebca3f0e25363c15179 (patch)
tree2f1659a5c755c53ff4a3fdd870a7bcd73b654b4f /dev-python/zipp/zipp-0.5.2.ebuild
parentdev-python/irc: remove old (diff)
downloadgentoo-b1a3d3c12b3e8537665ddebca3f0e25363c15179.tar.gz
gentoo-b1a3d3c12b3e8537665ddebca3f0e25363c15179.tar.bz2
gentoo-b1a3d3c12b3e8537665ddebca3f0e25363c15179.zip
dev-python/zipp: bump to 0.5.2
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/zipp/zipp-0.5.2.ebuild')
-rw-r--r--dev-python/zipp/zipp-0.5.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/zipp/zipp-0.5.2.ebuild b/dev-python/zipp/zipp-0.5.2.ebuild
new file mode 100644
index 000000000000..2d0e62d3d6e3
--- /dev/null
+++ b/dev-python/zipp/zipp-0.5.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}