summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-23 13:52:05 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-23 13:52:32 +0200
commitdb89a0a60b43ae66dfb6b14338339c07b2ea78f3 (patch)
treec23db56ca7d1ecbb20961a6143cd36df2fbc2eb8 /dev-python/zipp
parentapp-emacs/meson-mode: bump to 0.3 (diff)
downloadgentoo-db89a0a60b43ae66dfb6b14338339c07b2ea78f3.tar.gz
gentoo-db89a0a60b43ae66dfb6b14338339c07b2ea78f3.tar.bz2
gentoo-db89a0a60b43ae66dfb6b14338339c07b2ea78f3.zip
dev-python/zipp: bump to 3.2.0
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 301e191fabb2..b6230e3f3b68 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.1.0.tar.gz 14808 BLAKE2B fb5524c2619e51c5f8c1b85fa819d1001e6296df6c9d5320c6ab3ec88fa5c932c139161e621d51b2827ef40402bb2492b8b08e470b7333e847495ec690024879 SHA512 bb8dea71eccc4f3b18fc816dae700582c3feb72f346e115bb2d1adc336f121304a285e4d5dad48d15b386b9e137c6e1d1793ef50d22b6bd697812a661817684e
+DIST zipp-3.2.0.tar.gz 16238 BLAKE2B d74781639c714342863a0532ac8bbfc4d8cdcd554b9ce2b0edf83dc26ac423231ac85323379b4923308f2319c828aca2e0bcd4bd136845e7026b09e1e16e108e SHA512 fc0c8a9f1fbbcdd0f70c536e7498605e0a338dd99abd65f16b360cb16f96c7860d422ce2b55f7b2c1bfd7e5c5b5ca3bf818a48bae19bfbf190d91d4778aed31a
diff --git a/dev-python/zipp/zipp-3.2.0.ebuild b/dev-python/zipp/zipp-3.2.0.ebuild
new file mode 100644
index 000000000000..6d3948459056
--- /dev/null
+++ b/dev-python/zipp/zipp-3.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Skip a potentially flaky performance test
+ sed -i -e '/^import func_timeout\|^ *@func_timeout\.func_set_timeout/d' \
+ -e 's/test_implied_dirs_performance/_&/' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ pytest --ignore zipp.py -vv || die "Tests fail with ${EPYTHON}"
+}