summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-12 14:17:07 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-12 14:19:16 -0600
commite99a95dd61a40035bca35c6246f5f57ffa860077 (patch)
tree1e561d318479b0bafed7f3ada6214b36254d258d /dev-python/zope-configuration
parentdev-python/zope-schema: add arm/arm64/ppc64 keywords underallarches (diff)
downloadgentoo-e99a95dd61a40035bca35c6246f5f57ffa860077.tar.gz
gentoo-e99a95dd61a40035bca35c6246f5f57ffa860077.tar.bz2
gentoo-e99a95dd61a40035bca35c6246f5f57ffa860077.zip
dev-python/zope-configuration: 4.3.1 bump
Fixes: https://bugs.gentoo.org/691536 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/zope-configuration')
-rw-r--r--dev-python/zope-configuration/Manifest1
-rw-r--r--dev-python/zope-configuration/zope-configuration-4.3.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zope-configuration/Manifest b/dev-python/zope-configuration/Manifest
index 2b7dd0f38cff..0f845081d118 100644
--- a/dev-python/zope-configuration/Manifest
+++ b/dev-python/zope-configuration/Manifest
@@ -1 +1,2 @@
DIST zope.configuration-4.1.0.tar.gz 77780 BLAKE2B a3f0da446bbc858e43ccd4249c80db07b1f29df1fc31931c07bcd55116084a70b9618b15f22a8f1027e1fc53c8e2a7ba75bb3a80d8419c16cbef8f847299a3de SHA512 86bbc5ac22c61d485fcb55c4dafb5b81eaab0a08de1e5dc3cd586769323a09896e72b1e8aac790d3e8d8f93a133efd3f88a92a4b3c1075bdd0da62cd4e33c56a
+DIST zope.configuration-4.3.1.tar.gz 83223 BLAKE2B 9c55951932f34484fa6760a6a3cbdf89fbf8723c43b9b4ea2cf909b74716bcdd74d03327fc418f43bcfc8b6b5c17554cf8d062952d8d6880e49e6b270da9c1c8 SHA512 bc8edf84a391cab4f664ea3a4d24b65cb9db351c972b6118e69fe3c726bbe3337121ff59d687dddf463b3672ed6996f21d4437941c81dc456a4e5d837e0945d2
diff --git a/dev-python/zope-configuration/zope-configuration-4.3.1.ebuild b/dev-python/zope-configuration/zope-configuration-4.3.1.ebuild
new file mode 100644
index 000000000000..fe5dcefb34b1
--- /dev/null
+++ b/dev-python/zope-configuration/zope-configuration-4.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_6,3_7})
+
+inherit distutils-r1
+MY_PN=zope.configuration
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope Configuration Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.configuration
+ https://docs.zope.org/zope.configuration/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/zope-schema-4.9[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}