summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-19 23:56:49 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-19 23:56:49 -0400
commit8c85fa2eff49c4a2a306c09a4c483eb71519bec2 (patch)
tree9f5e37c6df5462a4b20e5373a0b3089d8c3fe401 /dev-python/zope-event/zope-event-4.3.0.ebuild
parentdev-python/certifi: version bump to 2017.7.27.1 (diff)
downloadgentoo-8c85fa2eff49c4a2a306c09a4c483eb71519bec2.tar.gz
gentoo-8c85fa2eff49c4a2a306c09a4c483eb71519bec2.tar.bz2
gentoo-8c85fa2eff49c4a2a306c09a4c483eb71519bec2.zip
dev-python/zope-event: version bump to 4.3.0
Diffstat (limited to 'dev-python/zope-event/zope-event-4.3.0.ebuild')
-rw-r--r--dev-python/zope-event/zope-event-4.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/zope-event/zope-event-4.3.0.ebuild b/dev-python/zope-event/zope-event-4.3.0.ebuild
new file mode 100644
index 000000000000..beab379acd88
--- /dev/null
+++ b/dev-python/zope-event/zope-event-4.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+MY_PN=zope.event
+
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Event publishing / dispatch, used by Zope Component Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.event http://docs.zope.org/zope.event/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}