summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-13 12:42:47 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-30 09:28:04 +0100
commit6afd93e38843fed0a30ddf8c501e188fb8d74a4f (patch)
tree96aa79c5038bd55437a750e9c08f31f5f1e4003e /dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.0.ebuild
parentdev-python/zope-testrunner: Fix MissingTestRestrict (diff)
downloadgentoo-6afd93e38843fed0a30ddf8c501e188fb8d74a4f.tar.gz
gentoo-6afd93e38843fed0a30ddf8c501e188fb8d74a4f.tar.bz2
gentoo-6afd93e38843fed0a30ddf8c501e188fb8d74a4f.zip
dev-python/zope-i18nmessageid: bump v5.0.0, EAPI=7
add python3_7, python3_8 add tests use distutils_enable_tests for tests Closes: https://bugs.gentoo.org/691538 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.0.ebuild')
-rw-r--r--dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.0.ebuild b/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.0.ebuild
new file mode 100644
index 000000000000..03fd892549b4
--- /dev/null
+++ b/dev-python/zope-i18nmessageid/zope-i18nmessageid-5.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope i18nmessageid Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.i18nmessageid http://docs.zope.org/zope.i18nmessageid/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}