summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-15 20:47:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-15 22:55:50 +0300
commit9f26a0ba54bb0e377b6e9159dc79876376677423 (patch)
tree349dc2177338d705d4073c6e920517d09789ab2b /dev-python/zope-schema
parentdev-python/pyupgrade: add 2.38.0 (diff)
downloadgentoo-9f26a0ba54bb0e377b6e9159dc79876376677423.tar.gz
gentoo-9f26a0ba54bb0e377b6e9159dc79876376677423.tar.bz2
gentoo-9f26a0ba54bb0e377b6e9159dc79876376677423.zip
dev-python/zope-schema: add 6.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/zope-schema')
-rw-r--r--dev-python/zope-schema/Manifest1
-rw-r--r--dev-python/zope-schema/zope-schema-6.2.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/zope-schema/Manifest b/dev-python/zope-schema/Manifest
index 77b5b037d689..1ae6fb9c5c85 100644
--- a/dev-python/zope-schema/Manifest
+++ b/dev-python/zope-schema/Manifest
@@ -1 +1,2 @@
DIST zope.schema-6.2.0.tar.gz 104068 BLAKE2B 10d300b925f57a028b40bbcdfd7b0eb330815b63c86d6ded60fb594d549b1459cb67a99bd19e6d1782104a8bab204d8033ce422b5f9ebddb00e2fdfc1ab7d529 SHA512 f3083e4fc1dc54160c38cf7033519f9f37fef3e39f2f15b53fc4475d0989932448a018d77f8562870f4df85c5bf35bc756aec97868cd35ca07b733cf5796f00f
+DIST zope.schema-6.2.1.tar.gz 124649 BLAKE2B 71ac712d3dbd6c9063ddc213263ce3a356f0ec757466cacdbc216af95cdb9de3ca7f891c203880f9f22612e01259491d83c49fcbe9985ecaabf1629ea14e12ea SHA512 e3fabd3deabb4ac2087792be94b919b7c9a0f0c741316d6f67a42e24fe617091754183b32d8433664b6fa95569009def8e7e1e08f34013282b042eb32da323a6
diff --git a/dev-python/zope-schema/zope-schema-6.2.1.ebuild b/dev-python/zope-schema/zope-schema-6.2.1.ebuild
new file mode 100644
index 000000000000..8157f0091af8
--- /dev/null
+++ b/dev-python/zope-schema/zope-schema-6.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Zope schema Architecture"
+HOMEPAGE="
+ https://pypi.org/project/zope.schema/
+ https://github.com/zopefoundation/zope.schema/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-5.0.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+BDEPEND="
+ test? (
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}