summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-25 15:09:04 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-25 15:09:04 +0200
commit34bbe081a75fbdb9084c6d911a916874bc637cea (patch)
tree668da72f93b1747913f5b959011cbf04913bfacb /dev-python/zstandard/zstandard-0.8.1.ebuild
parentx11-drivers/xf86-video-nouveau: Version bump to 1.0.15 (diff)
downloadgentoo-34bbe081a75fbdb9084c6d911a916874bc637cea.tar.gz
gentoo-34bbe081a75fbdb9084c6d911a916874bc637cea.tar.bz2
gentoo-34bbe081a75fbdb9084c6d911a916874bc637cea.zip
dev-python/zstandard: Version bump to 0.8.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/zstandard/zstandard-0.8.1.ebuild')
-rw-r--r--dev-python/zstandard/zstandard-0.8.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/zstandard/zstandard-0.8.1.ebuild b/dev-python/zstandard/zstandard-0.8.1.ebuild
new file mode 100644
index 000000000000..49d2780b47da
--- /dev/null
+++ b/dev-python/zstandard/zstandard-0.8.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Zstandard Bindings for Python"
+HOMEPAGE="https://pypi.python.org/pypi/zstandard https://github.com/indygreg/python-zstandard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/cffi:=[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"