summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-19 09:12:43 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-19 09:12:43 +0200
commit005ecf24a13f2fd873fab21a259038791931fa02 (patch)
tree1dd566db992046258f2530ffcc9caeb440a7a00c /dev-python/zstandard
parentdev-python/httpcore: add 0.14.5 (diff)
downloadgentoo-005ecf24a13f2fd873fab21a259038791931fa02.tar.gz
gentoo-005ecf24a13f2fd873fab21a259038791931fa02.tar.bz2
gentoo-005ecf24a13f2fd873fab21a259038791931fa02.zip
dev-python/zstandard: add 0.17.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/zstandard')
-rw-r--r--dev-python/zstandard/Manifest1
-rw-r--r--dev-python/zstandard/zstandard-0.17.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/zstandard/Manifest b/dev-python/zstandard/Manifest
index 093e0aae667c..e1832b9534a5 100644
--- a/dev-python/zstandard/Manifest
+++ b/dev-python/zstandard/Manifest
@@ -1 +1,2 @@
DIST zstandard-0.16.0.tar.gz 563633 BLAKE2B 8d896dcbd8ef9f9b28825d35792d02c3c447fa82ccef067deb925394c21da8f19a7faa4fbe84700fe5a0871af6d33d218c6134829d08eed93fd5ef43c3d0058c SHA512 f528cace58c1f1ec0fbea96e1646d92b05077ab6f5919eec07dc7b4fcfadf97dc848238928276fdb4333fb2cd035509af472ee352608661c3de681bc8dbed318
+DIST zstandard-0.17.0.tar.gz 629456 BLAKE2B 2b19c017b6255eaa22037e633f1f1dea1322c21dda3f1129e9593c5782b6cf3dbba12003711f6192bfa474a918cbf1eae2b5dd21fbf78731b8dfc62e69a27048 SHA512 312aa02c7309fac64cf70ca901942118d4b3f12f27d20cc18dcaba5ce155ad81ea8d7657501a33a5fb6cdc8bcca11f91141ea9d6c3fc09c28a84d698b9050391
diff --git a/dev-python/zstandard/zstandard-0.17.0.ebuild b/dev-python/zstandard/zstandard-0.17.0.ebuild
new file mode 100644
index 000000000000..2d942b9c0f95
--- /dev/null
+++ b/dev-python/zstandard/zstandard-0.17.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Zstandard Bindings for Python"
+HOMEPAGE="https://pypi.org/project/zstandard/ https://github.com/indygreg/python-zstandard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="
+ app-arch/zstd:="
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '>=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]' 'python*')
+"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # the C backend is repeatedly broken, so force CFFI instead
+ sed -e '/PYTHON_ZSTANDARD_IMPORT_POLICY/s:default:cffi:' \
+ -i zstandard/__init__.py || die
+ # unreliable, fails on x86
+ sed -e 's:test_estimated_compression_context_size:_&:' \
+ -i tests/test_data_structures.py || die
+
+ distutils-r1_src_prepare
+
+ DISTUTILS_ARGS=(
+ --no-c-backend
+ --system-zstd
+ )
+}