summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-14 09:45:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-14 10:29:27 +0200
commit2f4243913db8284289b0e247e207818d06f61c14 (patch)
tree7ef98dbfe151b9389cc264e6583db430a6b6172d /dev-python/zstandard
parentdev-python/boto3: Bump to 1.14.2 (diff)
downloadgentoo-2f4243913db8284289b0e247e207818d06f61c14.tar.gz
gentoo-2f4243913db8284289b0e247e207818d06f61c14.tar.bz2
gentoo-2f4243913db8284289b0e247e207818d06f61c14.zip
dev-python/zstandard: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zstandard')
-rw-r--r--dev-python/zstandard/Manifest1
-rw-r--r--dev-python/zstandard/zstandard-0.14.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/zstandard/Manifest b/dev-python/zstandard/Manifest
index da9c39eb5cec..d9b5fe56778c 100644
--- a/dev-python/zstandard/Manifest
+++ b/dev-python/zstandard/Manifest
@@ -1,3 +1,4 @@
DIST zstandard-0.12.0.tar.gz 648827 BLAKE2B bb644150e4126997d447dad3e5aec9f6e15ee344366634772d75b246a9ab82fad13f85ce986f36e45331fff26449b05a0864ad77d949def8cb024f598a218c74 SHA512 ebf896a77ce5cdc82a1edb658a0b96bcf99deee7aa031163879fc21fe3d03623061182fd2c11840a5a46a8ad0a08b98b802b4703b963d448a25c0b52685d3b64
DIST zstandard-0.13.0.tar.gz 659422 BLAKE2B 8ebdb7f7ca1671fa87cc1bb8a67cde4f408c49b9146041ca2a713a1457d9a4acfed5335484294d61b076f4a8e42ab3b2bcd0d09b4af54fca3a82a511c73d6d83 SHA512 3a6151de640515f21626d150e1295c1f2e524d377b3b1ccabf2719fae6da89f95480a50ec80eac4d07d317c7abe50ed7a26162b3291169e139c4ddd71b6ada98
+DIST zstandard-0.14.0.tar.gz 676761 BLAKE2B f90fcee6571f89eb5964ba50c722be8f3b846a0aaa6f79bd41389131ce332a4c6f7ec3d2eabd16268a42d211c7c02c2f7379019ef44272eb23cc74a20e5e9b3d SHA512 57c62eb7dedde2a2178f79a5658b87b5c5f176b282311273953003824272afa03e126a79b57fc8b75e9e15585d44d6b9931318a8ea5e7c75ec0feebbd7eb6cf0
DIST zstandard-0.8.1.tar.gz 463785 BLAKE2B ac4dce58cefa05d265824004464bad89a7f4c4e5f19ac1d8b5b8b0ad6f806318e2b82ffb6f3a290e3605961801909b339b1e5d89fdccd76fd28c75a695a92e0a SHA512 0ddbe22381397443c6c9f84e64f9358160bede104c4f48351119d880ac4f88994739b0b3915454567d2b2b04930c6ead5aa290a40323ba4b0bacf5e97809793c
diff --git a/dev-python/zstandard/zstandard-0.14.0.ebuild b/dev-python/zstandard/zstandard-0.14.0.ebuild
new file mode 100644
index 000000000000..2f9ab74169ae
--- /dev/null
+++ b/dev-python/zstandard/zstandard-0.14.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6..9}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Zstandard Bindings for Python"
+HOMEPAGE="https://pypi.org/project/zstandard/ https://github.com/indygreg/python-zstandard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+python_compile() {
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}