summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-12-05 15:37:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-12-05 15:37:00 -0800
commitb1d0590483d7b902f6da5471a7775806cca9eed0 (patch)
tree4195f97fcdb649bd53520fda6186c0c0c1c0e225 /dev-python/zstandard
parentmedia-libs/libquvi: bump to EAPI=7, drop multilib eclass (diff)
downloadgentoo-b1d0590483d7b902f6da5471a7775806cca9eed0.tar.gz
gentoo-b1d0590483d7b902f6da5471a7775806cca9eed0.tar.bz2
gentoo-b1d0590483d7b902f6da5471a7775806cca9eed0.zip
dev-python/zstandard-0.14.1: Version bump
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/zstandard')
-rw-r--r--dev-python/zstandard/Manifest1
-rw-r--r--dev-python/zstandard/zstandard-0.14.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/zstandard/Manifest b/dev-python/zstandard/Manifest
index 25c4d309a5b9..5588bf0ef9b2 100644
--- a/dev-python/zstandard/Manifest
+++ b/dev-python/zstandard/Manifest
@@ -1,2 +1,3 @@
DIST zstandard-0.14.0.tar.gz 676761 BLAKE2B f90fcee6571f89eb5964ba50c722be8f3b846a0aaa6f79bd41389131ce332a4c6f7ec3d2eabd16268a42d211c7c02c2f7379019ef44272eb23cc74a20e5e9b3d SHA512 57c62eb7dedde2a2178f79a5658b87b5c5f176b282311273953003824272afa03e126a79b57fc8b75e9e15585d44d6b9931318a8ea5e7c75ec0feebbd7eb6cf0
+DIST zstandard-0.14.1.tar.gz 676849 BLAKE2B ad2a89371301e64428de90adf8770ebb7b43b06d720f5e0e9b490dc8771c55a974625105128c3a8052d68230d2670a802adfbf64708729440fdf624ca8d4fccb SHA512 e49f294816f0c7da35914363dbbdfcc4d432f7fa8367192e07a5d0c093ec8af76966fd0a95b4e8316091f056a8027c383ca73cc9ed506b29e2f9a31bc9ad3379
DIST zstandard-0.8.1.tar.gz 463785 BLAKE2B ac4dce58cefa05d265824004464bad89a7f4c4e5f19ac1d8b5b8b0ad6f806318e2b82ffb6f3a290e3605961801909b339b1e5d89fdccd76fd28c75a695a92e0a SHA512 0ddbe22381397443c6c9f84e64f9358160bede104c4f48351119d880ac4f88994739b0b3915454567d2b2b04930c6ead5aa290a40323ba4b0bacf5e97809793c
diff --git a/dev-python/zstandard/zstandard-0.14.1.ebuild b/dev-python/zstandard/zstandard-0.14.1.ebuild
new file mode 100644
index 000000000000..86f9c0f9f030
--- /dev/null
+++ b/dev-python/zstandard/zstandard-0.14.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Zstandard Bindings for Python"
+HOMEPAGE="https://pypi.org/project/zstandard/ https://github.com/indygreg/python-zstandard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+python_compile() {
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}