summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 09:32:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 09:32:57 +0200
commit639654ff04d515b119843831483e796d7bd5df54 (patch)
treef932f0ca3f5c8475e2ed8411b892f4e88d85f49f /dev-python/zxcvbn
parentdev-python/guessit: Enable py3.11 (diff)
downloadgentoo-639654ff04d515b119843831483e796d7bd5df54.tar.gz
gentoo-639654ff04d515b119843831483e796d7bd5df54.tar.bz2
gentoo-639654ff04d515b119843831483e796d7bd5df54.zip
dev-python/zxcvbn: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zxcvbn')
-rw-r--r--dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild b/dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild
new file mode 100644
index 000000000000..f1cc4de7e891
--- /dev/null
+++ b/dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A realistic password strength estimator"
+HOMEPAGE="
+ https://github.com/dwolfhub/zxcvbn-python/
+ https://pypi.org/project/zxcvbn/
+"
+SRC_URI="
+ https://github.com/dwolfhub/zxcvbn-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/zxcvbn-python-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests pytest