summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-23 10:54:42 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-23 11:05:31 +0100
commit015c1f58eed5da83e9b4602b91fb34f898c8a3a6 (patch)
treefd62c2c9a68804c6317217be66f39ed2754a7ab2 /dev-python
parentdev-python/pytest: Drop old (diff)
downloadgentoo-015c1f58eed5da83e9b4602b91fb34f898c8a3a6.tar.gz
gentoo-015c1f58eed5da83e9b4602b91fb34f898c8a3a6.tar.bz2
gentoo-015c1f58eed5da83e9b4602b91fb34f898c8a3a6.zip
dev-python/pip: Drop vulnerable versions for CVE-2014-8991 and CVE-2013-5123
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=529954 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=501752 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pip/Manifest2
-rw-r--r--dev-python/pip/pip-1.5.6.ebuild38
-rw-r--r--dev-python/pip/pip-7.1.0.ebuild40
3 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index 58ff0846657b..0a63ead9ab56 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,3 +1 @@
-DIST pip-1.5.6.tar.gz 938120 SHA256 b1a4ae66baf21b7eb05a5e4f37c50c2706fa28ea1f8780ce8efe14dcd9f1726c SHA512 cecd1da900e95bf3e6164e6d0c8c989e8ce17ef892beb9581a567857fe69dd3490b45d366cbb8e3bc84cebcf62ecf34420bcc1fae3fd8cf448927438ae257b68 WHIRLPOOL d6b77000ec465f8ba15db9dd4ce23c491937d5c7ee8fa148cf1cc88d59e972ad0a4a86adeca0d6b5227e97e83c16ae6d14b76976b605db572c08ac7019a02e6d
-DIST pip-7.1.0.tar.gz 1049267 SHA256 d5275ba3221182a5dd1b6bcfbfc5ec277fb399dd23226d6fa018048f7e0f10f2 SHA512 abda274dfe5f81e121bef9b3bf7a64218f72786037c17b0d99f36c954b09d6b5200a8b78f43de4739c813628a49cbb9d300e869766958e4ed177cf9caad8d511 WHIRLPOOL 35b2953c00a2ff4838f5f550016292b125f06d10f90736b96efc2240dadeebbba8be3d1b860efbe9989bffd51f5a6c5fa43234615b513cdc1aa900df8eb25f2a
DIST pip-7.1.2.tar.gz 1049170 SHA256 ca047986f0528cfa975a14fb9f7f106271d4e0c3fe1ddced6c1db2e7ae57a477 SHA512 78082afe6b559bf87f91ae9b6d304cfbfce00206e09be42fdae9d449a55cd8d968df6873e834191d0b0e6baae29e72eb3eee42386ff7c5dc9c29b6c28b754449 WHIRLPOOL 953fdc9104f3ac34c9104ec93948f58c4b0e193f18da60d3247d801c283c574490f8b91146e4278888c0b920090f537095c1a1693ca352d062dd98473390fdc9
diff --git a/dev-python/pip/pip-1.5.6.ebuild b/dev-python/pip/pip-1.5.6.ebuild
deleted file mode 100644
index d0560d95e405..000000000000
--- a/dev-python/pip/pip-1.5.6.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ https://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
-}
diff --git a/dev-python/pip/pip-7.1.0.ebuild b/dev-python/pip/pip-7.1.0.ebuild
deleted file mode 100644
index 3af6fa041e16..000000000000
--- a/dev-python/pip/pip-7.1.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ https://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch )
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
-}