summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-10 07:25:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-10 10:15:52 +0100
commit017da203430fec2698059c5dee3deb3cc09a3c66 (patch)
tree950c1f17e4283366f50ee7193bac86484dfe28a3 /dev-python
parentdev-python/python-multipart: Bump to 0.0.8 (diff)
downloadgentoo-017da203430fec2698059c5dee3deb3cc09a3c66.tar.gz
gentoo-017da203430fec2698059c5dee3deb3cc09a3c66.tar.bz2
gentoo-017da203430fec2698059c5dee3deb3cc09a3c66.zip
dev-python/starlette: Bump to 0.37.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.37.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 773e116e9b97..b7932fde27dc 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -3,3 +3,4 @@ DIST starlette-0.36.1.gh.tar.gz 2843494 BLAKE2B 633cd664785f32423c0dfeab04b40034
DIST starlette-0.36.2.gh.tar.gz 2843707 BLAKE2B 7ec75189d7e9864fe15823692d2d264586be8772a0ff29e1d539eb15f858ef9d77ef6398e203f5c2f8a507869026fd8863931a176923f29bf11457e58cdb66fa SHA512 fedccb1db4cfe4a0dac321c843ae211e436ec5b07c0e65b663914657a9cec61a900d95dac09b6752a51defbb310a8dce30f0867574523a3c96cf33cd19b61c76
DIST starlette-0.36.3.gh.tar.gz 2844320 BLAKE2B 74e2b7449cf18393c63a2123e7537704bcf85528d504c33dc579b7660ef13c11fe74ba4da6e680063d9849f5addddaeaa5c20cc770bf658613b56da2f7d9191d SHA512 998e8958810efbc329382d86f6084d7ed90dca68bb64c51349b2dae6740ba537db10ec68a007e95a81ab06f5df39c64d998b3e87432a8fc75da3ead0963bcc5d
DIST starlette-0.37.0.gh.tar.gz 2845423 BLAKE2B f471d6170cecc0a4421b865306a76147e3c946892abef3a5f8e04a03e8aab830c5702079db9af81ef8eaaba9812286c1364599e556fb4a3c4aae511849d706a3 SHA512 7750d76f2c7d8ee5aba47ba21583d0167c16965538a3735c9098ea44c6f335d893f314550b90ddf2ac9dd592fb777f5cd8035020d7c31cff46e4813b3194730f
+DIST starlette-0.37.1.gh.tar.gz 2846156 BLAKE2B 16645f53f3153c04b846776c09b978dda853319f561d136eed42a5da260705238e512f915fd4a86960f0723060270738972ff12f78a3de37c78c7698585a7011 SHA512 ad5393a06966f290976fd60038c56a6ec71c5424bf50298a76ab8f165db4cac81f62cd4b9181e4e573eca4eb1ffeaa64eb44eaa43d41485ef62678af59c8e0dc
diff --git a/dev-python/starlette/starlette-0.37.1.ebuild b/dev-python/starlette/starlette-0.37.1.ebuild
new file mode 100644
index 000000000000..31b21741ddd7
--- /dev/null
+++ b/dev-python/starlette/starlette-0.37.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/python-multipart-0.0.7[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest