summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-05 20:30:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-05 20:53:00 +0300
commit0308011888ce78ce6adf6843e39ecb8e2d6f1460 (patch)
treee5a8e895cee5f55fa1ec6104c1680293e4086d57 /dev-python
parentsci-geosciences/gpxsee: bump to 11.1 (diff)
downloadgentoo-0308011888ce78ce6adf6843e39ecb8e2d6f1460.tar.gz
gentoo-0308011888ce78ce6adf6843e39ecb8e2d6f1460.tar.bz2
gentoo-0308011888ce78ce6adf6843e39ecb8e2d6f1460.zip
dev-python/pid: EAPI=8, Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pid/pid-3.0.4-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pid/pid-3.0.4-r1.ebuild b/dev-python/pid/pid-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..07f18c7fe3bd
--- /dev/null
+++ b/dev-python/pid/pid-3.0.4-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.org/project/pid/ https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest