summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-03 06:08:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-03 06:08:12 +0200
commit0379140d31a30f361d9b13f1661d0626318c059a (patch)
tree3ebcdab2516e7f353180512cf850ba70ab5032d7 /dev-python
parentdev-python/griffe: Bump to 0.30.1 (diff)
downloadgentoo-0379140d31a30f361d9b13f1661d0626318c059a.tar.gz
gentoo-0379140d31a30f361d9b13f1661d0626318c059a.tar.bz2
gentoo-0379140d31a30f361d9b13f1661d0626318c059a.zip
dev-python/zeroconf: Bump to 0.70.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.70.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index ae6128dc3cdb..20cb0dec6502 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -5,3 +5,4 @@ DIST zeroconf-0.64.1.tar.gz 142617 BLAKE2B 100243491aa85b9be8a7664ad9de6f1b202d0
DIST zeroconf-0.66.0.tar.gz 142962 BLAKE2B 7cc625ea71e00a4e1f47589de1e8168c6299396f1f50d5ba6b530040a0d97ce40b1e858bb76eaaa3e8796c5cc793d819f0b31d693340f2ba5f26cf17d8db3f28 SHA512 544bccaf1acf2a3861c3e0131836f4ccd5d5aadc7222cf34f02ccae61abf32cf7430925698f13d14cf16a62ea9875df6e37fc5e93abfb02dbed79cb1e2e47fe3
DIST zeroconf-0.68.0.tar.gz 143138 BLAKE2B fc0bdd42245339abf4a283a4f3dba9b820c02074fb78066d9867bf7cdd06c17f2cc5452fdfe3dab93bd3427d800b4901a6cb398593c5beb2495d89b240f3df13 SHA512 6f72391e9486debdb588c3f4e262530b584be967bcb524758e025035aec53ed49fbcee8f9e2c0caaf9a94f2fc5b9c19e5d88e83f1ca909be8d2049f8e2b4e43b
DIST zeroconf-0.69.0.tar.gz 143434 BLAKE2B 1c80eff0395167879b0d782d1b0fc5f6102a95271682212de11983bd523565622b52ec13591445b4e4015fffa6a94d6b023d7addb6f05b4c1dfd65ce4181d9f5 SHA512 6f9799fe7810cf5357e378435308d87eeef1279768581f1704201f2aa7683a324b4bae697099259b3a85012a8de412bf892aa264322349b2f98d676b392482c2
+DIST zeroconf-0.70.0.tar.gz 143727 BLAKE2B dc7d44e69ebfad71519acfe32ea91dc165b9813c0d16feb4f663845fe532f0b696a2d384a2b5a7091c3b759d484b6d80275a8e70dfa0b9605909bf2758599a1d SHA512 37dc1fde285b09fa2654de685a1dbbbcf35834147ff2f7115ccf569e404d92ff116a5b437a53ef6f40252641ad810cfd862e2d5db6cd76ed2120fb658b50c001
diff --git a/dev-python/zeroconf/zeroconf-0.70.0.ebuild b/dev-python/zeroconf/zeroconf-0.70.0.ebuild
new file mode 100644
index 000000000000..547370f5f4c2
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.70.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}