summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-25 08:19:01 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-25 08:19:01 -0500
commit0569e4c3d03d29f80458ad6161f938bb665bffb1 (patch)
tree003b556a1bc015823ef598db610e7dd8ce4d3183 /dev-python
parentmedia-sound/abcmidi: version bump to 2017.11.19 (diff)
downloadgentoo-0569e4c3d03d29f80458ad6161f938bb665bffb1.tar.gz
gentoo-0569e4c3d03d29f80458ad6161f938bb665bffb1.tar.bz2
gentoo-0569e4c3d03d29f80458ad6161f938bb665bffb1.zip
dev-python/hypothesis: version bump to 3.38.5
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.38.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 1f4f8e8284d7..95f1e4bf1399 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,4 +2,5 @@ DIST hypothesis-3.31.1.tar.gz 464365 SHA256 b2e5413e5424b433f013f4c7c5308130a55f
DIST hypothesis-3.33.0.tar.gz 467424 SHA256 cd10a68b65b160da6c957557255dc2aa89c8967c21169a79d765d4aae1d2a929 SHA512 3e89fa183381f2df556016ff4af17d2731685b019aed74d5f8dccd53ad262dce107f83f105b7e950a579ef247cc9b8336f15ee321292522118fa4c3487a21138 WHIRLPOOL ce1d30d72880d841c116dc2b8edd700fa483c845d7c7271efeceb94ba3336e5ed9493d0032c8aa4efb15d67a95490f3bb556b63a4be6168c53ed06406558808b
DIST hypothesis-3.34.1.tar.gz 468030 SHA256 331a185a60bb4321073219b73516435923744c07f06c4bed188ddba8078bb247 SHA512 d061c67551c7f877fd7b046ab8164fd01f73f8b013f257817a4e85177f0b8b1782d333d79b492e07771ecdb54ca4451fbcc6271cae19f9a9040160cc45db0644 WHIRLPOOL 7b33284a141b1f8e75e225a82cffae71621a946e48c9d48818fa3870d584347d6b0dcfdfb12b45700970a7ff1400e26fba4e9ff8fbc422b472d11eb1a21798d8
DIST hypothesis-3.37.0.tar.gz 469019 SHA256 335d18ee7ccecd5e883b4b54b042d65d25b13b76b96eefe1e6df473f99b8c841 SHA512 41dae6f4d9bbddc89fc174e3cb3a9f09d16bfc1903ab75980a243614505eeb792bb00bc2b803e2272b2d6fce901f250e0f82ea9ea647ada868019ce01aa98618 WHIRLPOOL a1a21aae82c51164cedacad039e9ce5480977d5d82cc07468dd086f4a94048833a336b4dd09f39d22ebf53c5c0757abe28654ae75b95a0b20547e8905b21fcc1
+DIST hypothesis-3.38.5.tar.gz 474087 BLAKE2B a3182701463e03383cf4d5fb16605d494c5339a23ea77d789d27eaaf576ee3c2c81a7ebfcb4641b15b9c19755d85a6f0d36555f8091bef8986e8afb290eedc85 SHA512 bd13bda0adf2fc1629c41c6b5b63744f1b33b0b9cfbcd4b78c73b8ab9cde2db50e2c084216c4123f93efc2355d4d45d3d6e51b079d8722341deb5df24fedf6b1
DIST hypothesis-3.6.0.tar.gz 73586 SHA256 ecb0e711ab83032c54605d88fda1e07ca5c6025bdb5e91deab96eca29491f678 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389 WHIRLPOOL 189c788fdd0a326879a468061c271b14056da5f7dc1d5975e8f360cd5a91957eb8f79c26a045fbe49d7b11f7cc09024d3d09a353321b1dda1d4d96b452fd9e7b
diff --git a/dev-python/hypothesis/hypothesis-3.38.5.ebuild b/dev-python/hypothesis/hypothesis-3.38.5.ebuild
new file mode 100644
index 000000000000..4869c0b7b9eb
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.38.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis-python https://pypi.python.org/pypi/hypothesis"
+SRC_URI="https://github.com/HypothesisWorks/hypothesis-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}-python-${PV}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}