summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-02 21:14:01 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-02 21:34:04 +0300
commit07517e27dbf5aa4ca6454338e8f4e26498e9226d (patch)
treee113a2ee6dfc68d4b5ba4b700ef76857a9fe039e /dev-python
parentdev-python/platformdirs: add 3.11.0 (diff)
downloadgentoo-07517e27dbf5aa4ca6454338e8f4e26498e9226d.tar.gz
gentoo-07517e27dbf5aa4ca6454338e8f4e26498e9226d.tar.bz2
gentoo-07517e27dbf5aa4ca6454338e8f4e26498e9226d.zip
dev-python/urllib3: add 2.0.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/urllib3-2.0.6.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 9ebdf4b3c07f..18a11f5624a0 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1,4 @@
DIST urllib3-1.26.16.tar.gz 303733 BLAKE2B 94c0cfb8696b15ff7aed25927ba584d0d67b150953586ca4d74ddc8f1d0a95ca447a482cf7d0f95728fad1e7e51a610e29c3e342ebe68e65a86789308544ea51 SHA512 caa58af5bf49644459a9074be659511b56c5d66802153c72ba2ba2eb9c0aafd56b4cd8f8588964ee7d2a9b16a5e114d62298ab1e128710260ed86f1e315b5571
DIST urllib3-2.0.4.tar.gz 281517 BLAKE2B 58635787069b6d8e83394ddacca2c70824c03190efb4e0838b9b80d8e8c1499fa0143e1d38ece4e2a7f9b34d6b50f9805050bf85707d98eb171307ff35f8b215 SHA512 64d55714d871716730af5a691fc222722cffc13b0603ecae597e5f4cfd82297beede2b08cedc030b2419bd446f51c4c6e54f466ad96c71dd0848abbf806b4db4
DIST urllib3-2.0.5.tar.gz 281697 BLAKE2B 7ae1cc90243cd2069767d4a3f7ca3b96d9e6270f38b363ba2c2cfddeb293cc75782740524bdf91d64bd08dcf1dc44cb9fe6ec2b501d34bdf4c69d893c794382a SHA512 dead3fcda9637c6142b577f051f25578249f7513d3d2bdf4ed880b7a063ff7ee2e946e72b91355328b12205600abc487252ca025f3946408093df46134d9fc12
+DIST urllib3-2.0.6.tar.gz 281846 BLAKE2B 3af632a77f07d5c686e6412b06d67df5c62517239431ead7d0c7e7bbb5efe06c298db0afda1a84fb314f3e3936edd16aef693ac316a923f67232abf8789b6201 SHA512 872a5899ad4486b45fe7a327f029beb5f7d3dd8447b58b861922b32bd15f1cff68d12136f262c2d2d3740047976bc6cff16a54590c1eab19949149e7dae2956a
diff --git a/dev-python/urllib3/urllib3-2.0.6.ebuild b/dev-python/urllib3/urllib3-2.0.6.ebuild
new file mode 100644
index 000000000000..32852e31e793
--- /dev/null
+++ b/dev-python/urllib3/urllib3-2.0.6.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="
+ https://github.com/urllib3/urllib3/
+ https://pypi.org/project/urllib3/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="brotli test zstd"
+RESTRICT="!test? ( test )"
+
+# [secure] extra is deprecated and slated for removal, we don't need it:
+# https://github.com/urllib3/urllib3/issues/2680
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ brotli? ( >=dev-python/brotlicffi-0.8.0[${PYTHON_USEDEP}] )
+ zstd? ( >=dev-python/zstandard-0.18.0[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/freezegun[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[\${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[\${PYTHON_USEDEP}]
+ >=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.18.0[\${PYTHON_USEDEP}]
+ " "${PYTHON_TESTED[@]}")
+ )
+"
+
+src_prepare() {
+ # upstream considers 0.5 s to be "long" for a timeout
+ # we get tons of test failures on *fast* systems because of that
+ sed -i -e '/LONG_TIMEOUT/s:0.5:5:' test/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x CI=1
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # take forever
+ test/contrib/test_pyopenssl.py::TestSocketSSL::test_requesting_large_resources_via_ssl
+ test/with_dummyserver/test_socketlevel.py::TestSSL::test_requesting_large_resources_via_ssl
+ # stupid test, next bump please verify if they fixed it
+ test/test_poolmanager.py::TestPoolManager::test_deprecated_no_scheme
+ # fails with newer secure SSL configuration, which removes TLS 1.1
+ test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
+ test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
+ test/with_dummyserver/test_https.py::TestHTTPS_TLSv1::test_verify_none_and_good_fingerprint
+ test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_1::test_verify_none_and_good_fingerprint
+ # TODO: timeouts
+ test/contrib/test_pyopenssl.py::TestSocketClosing::test_timeout_errors_cause_retries
+ test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
+ # warnings, sigh
+ test/with_dummyserver/test_connectionpool.py::TestConnectionPool::test_request_chunked_is_deprecated
+ )
+
+ # plugins make tests slower, and more fragile
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # some tests are very fragile to timing
+ epytest -p rerunfailures --reruns=10 --reruns-delay=2 \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}