summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-22 09:23:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-22 09:58:04 +0200
commit07befc1671f4d931ebf9077e6667ec4b66b881a8 (patch)
tree54ea8af1b25e125bf0b5b5cbe7c6c6dad4d8b216 /dev-python
parentdev-python/pgspecial: Bump to 1.13.0 (diff)
downloadgentoo-07befc1671f4d931ebf9077e6667ec4b66b881a8.tar.gz
gentoo-07befc1671f4d931ebf9077e6667ec4b66b881a8.tar.bz2
gentoo-07befc1671f4d931ebf9077e6667ec4b66b881a8.zip
dev-python/wcmatch: Bump to 8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wcmatch/Manifest1
-rw-r--r--dev-python/wcmatch/wcmatch-8.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
index bbf3b1638603..df2a01535892 100644
--- a/dev-python/wcmatch/Manifest
+++ b/dev-python/wcmatch/Manifest
@@ -1 +1,2 @@
DIST wcmatch-8.1.2.tar.gz 112726 BLAKE2B 4d91425f30e81f1ff3449b364b74f242b7393b7a4a162538e57406f9d5cc05d24277d6c0119c40266d4474c9c99919ade8d0450b1999abb39077ffc64f495719 SHA512 f96fc646db334407229ee9885b308eb2b27967d9b4e4245df33641605af678f3edfb54f53c5c8722b946029d39779fcd775299963530036c723cfa860dcfff38
+DIST wcmatch-8.2.tar.gz 113537 BLAKE2B d1fe53f7d2394af31750c0b98451749201b1adbd8d00a734418afd8e208a9480b913059f78f62016be2fc2109813406c096f8ab60973a716b6ca275377551281 SHA512 d56d868ec0578ae59eb5f39ff17005faed13162141e3ced15c60d8de5f8e8b1a16eaf66e7c73cffdbd288b94db57843112624de8e5b588d26a5e46d4edb72168
diff --git a/dev-python/wcmatch/wcmatch-8.2.ebuild b/dev-python/wcmatch/wcmatch-8.2.ebuild
new file mode 100644
index 000000000000..9ec783dd32b7
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-8.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ ~dev-python/mkdocs_pymdownx_material_extras-1.0.7
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch/
+ https://pypi.org/project/wcmatch/"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/backrefs-4.1[${PYTHON_USEDEP}]
+ >=dev-python/bracex-2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tests require some files in homedir
+ > "${HOME}"/test1.txt || die
+ > "${HOME}"/test2.txt || die
+
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}