summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-01-14 12:15:50 -0500
committerMike Gilbert <floppym@gentoo.org>2017-01-14 12:16:36 -0500
commit07fe9f9199b537d80ce6b19d9baa6fce33843798 (patch)
treea0994910ae6ec5af9ab9d35092f9ff6fa8a4287c /dev-python
parent dev-ml/labltk: ia64 stable (diff)
downloadgentoo-07fe9f9199b537d80ce6b19d9baa6fce33843798.tar.gz
gentoo-07fe9f9199b537d80ce6b19d9baa6fce33843798.tar.bz2
gentoo-07fe9f9199b537d80ce6b19d9baa6fce33843798.zip
dev-python/sphinx-gallery: fixup nose dep
Remove setup_requires=['nose'] from setup.py. Package-Manager: Portage-2.3.3_p32, Repoman-2.3.1_p25
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
index 7f9ae300f5a9..dbc19a441f8b 100644
--- a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
@@ -15,7 +15,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/matplotlib[${PYTHON_USEDEP}]
@@ -24,10 +25,16 @@ RDEPEND="
"
# yes nose is somehow required besides testing
DEPEND="
- dev-python/nose[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.0[${PYTHON_USEDEP}] )
"
+python_prepare_all() {
+ # Remove setup_requires=['nose']
+ sed -i -e /setup_requires/d setup.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
echo 'backend: agg' > matplotlibrc
VARTEXFONTS="${T}"/fonts MPLCONFIGDIR="${BUILD_DIR}" \