summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-10 11:24:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-10 12:27:38 +0200
commit0843e5fe167de86901619c3182d36166dfd33b1f (patch)
tree4550e1545a39eb6f69e1cd90ca292c3c583e18b1 /dev-python
parentwww-plugins/adobe-flash: Old (diff)
downloadgentoo-0843e5fe167de86901619c3182d36166dfd33b1f.tar.gz
gentoo-0843e5fe167de86901619c3182d36166dfd33b1f.tar.bz2
gentoo-0843e5fe167de86901619c3182d36166dfd33b1f.zip
dev-python/blosc: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/blosc/blosc-1.9.1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/blosc/blosc-1.9.1.ebuild b/dev-python/blosc/blosc-1.9.1.ebuild
index 50df9cddf599..2cda56af6d43 100644
--- a/dev-python/blosc/blosc-1.9.1.ebuild
+++ b/dev-python/blosc/blosc-1.9.1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6..8} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -17,9 +19,9 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-libs/c-blosc:="
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-python/scikit-build[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
@@ -32,12 +34,6 @@ python_prepare_all() {
DOCS=( ANNOUNCE.rst README.rst RELEASE_NOTES.rst )
}
-python_compile_all() {
- esetup.py build_clib
- esetup.py build_ext --inplace
- esetup.py build
-}
-
python_test() {
cd "${BUILD_DIR}"/lib || die
PYTHONPATH=. nosetests -v || die