summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-17 08:39:03 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-17 09:07:43 +0100
commit08aea9001b73f5088f1e6063e3c0b58eb65246a7 (patch)
treeaf0977b3ca69faac6db3fd4697ff4f7ada224ac9 /dev-python
parentdev-python/stripe: Clean py2 deps up (diff)
downloadgentoo-08aea9001b73f5088f1e6063e3c0b58eb65246a7.tar.gz
gentoo-08aea9001b73f5088f1e6063e3c0b58eb65246a7.tar.bz2
gentoo-08aea9001b73f5088f1e6063e3c0b58eb65246a7.zip
dev-python/sympy: Clean py2 deps up
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sympy/sympy-1.0-r1.ebuild5
-rw-r--r--dev-python/sympy/sympy-1.3.ebuild5
-rw-r--r--dev-python/sympy/sympy-1.5.1-r1.ebuild5
-rw-r--r--dev-python/sympy/sympy-1.5.1.ebuild5
-rw-r--r--dev-python/sympy/sympy-1.5.ebuild5
5 files changed, 10 insertions, 15 deletions
diff --git a/dev-python/sympy/sympy-1.0-r1.ebuild b/dev-python/sympy/sympy-1.0-r1.ebuild
index a1b4f8b591ef..195f59d969c0 100644
--- a/dev-python/sympy/sympy-1.0-r1.ebuild
+++ b/dev-python/sympy/sympy-1.0-r1.ebuild
@@ -17,12 +17,11 @@ KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="examples gtk imaging ipython latex mathml opengl pdf png test texmacs"
RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
latex? (
virtual/latex-base
dev-texlive/texlive-fontsextra
diff --git a/dev-python/sympy/sympy-1.3.ebuild b/dev-python/sympy/sympy-1.3.ebuild
index 078dc48e8f85..ffc69e64f913 100644
--- a/dev-python/sympy/sympy-1.3.ebuild
+++ b/dev-python/sympy/sympy-1.3.ebuild
@@ -16,8 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test"
# All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
latex? (
virtual/latex-base
dev-texlive/texlive-fontsextra
diff --git a/dev-python/sympy/sympy-1.5.1-r1.ebuild b/dev-python/sympy/sympy-1.5.1-r1.ebuild
index cc961486a27d..aed3527e80ee 100644
--- a/dev-python/sympy/sympy-1.5.1-r1.ebuild
+++ b/dev-python/sympy/sympy-1.5.1-r1.ebuild
@@ -16,8 +16,7 @@ SLOT="0"
KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test"
# All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
latex? (
virtual/latex-base
dev-texlive/texlive-fontsextra
diff --git a/dev-python/sympy/sympy-1.5.1.ebuild b/dev-python/sympy/sympy-1.5.1.ebuild
index 5ecc82a06a54..dd759926e289 100644
--- a/dev-python/sympy/sympy-1.5.1.ebuild
+++ b/dev-python/sympy/sympy-1.5.1.ebuild
@@ -16,8 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test"
# All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
latex? (
virtual/latex-base
dev-texlive/texlive-fontsextra
diff --git a/dev-python/sympy/sympy-1.5.ebuild b/dev-python/sympy/sympy-1.5.ebuild
index c8dda8967474..3d8957d84cb9 100644
--- a/dev-python/sympy/sympy-1.5.ebuild
+++ b/dev-python/sympy/sympy-1.5.ebuild
@@ -16,8 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ipython? ( || ( $(python_gen_useflags -3) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test"
# All tests actually pass, except a bunch of tests related to the deprecated pygletplot
@@ -26,7 +25,7 @@ RESTRICT="test"
RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
latex? (
virtual/latex-base
dev-texlive/texlive-fontsextra