summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-18 05:40:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-18 06:41:28 +0200
commit0a3ee57fed3212186cd9b3d471f53fbfee35af8d (patch)
tree9d234109b21b1eeab87224f47873e4387fab75b4 /dev-python
parentapp-emacs/puppet-mode: add 0.4 (diff)
downloadgentoo-0a3ee57fed3212186cd9b3d471f53fbfee35af8d.tar.gz
gentoo-0a3ee57fed3212186cd9b3d471f53fbfee35af8d.tar.bz2
gentoo-0a3ee57fed3212186cd9b3d471f53fbfee35af8d.zip
dev-python/botocore: Bump to 1.20.97
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.97.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e0e8c5161237..c66fc190791d 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -18,3 +18,4 @@ DIST botocore-1.20.93.tar.gz 7827854 BLAKE2B 6297172731db3367d5d769c38de4d8ba8e3
DIST botocore-1.20.94.tar.gz 7830564 BLAKE2B 4c52bb0f782a4560c1c966ede26a5741428f5b06aea8a46f76956b7ebebeec92c6eecd62fd3064a3eeb206c68116a64104222dc141d860cc9d1c53eb37567c24 SHA512 1dbb52626b03f82b48cdf76da0e0138b11d47c9f6aef64a164c7489232a46af4f2d214fef5d132a1c656f2728608cecd23b4a781f58252ee7a69c7efe853d4f3
DIST botocore-1.20.95.tar.gz 7833074 BLAKE2B f7c6f01cf28f609a2a6c2cdcb41240d3d653a12ca28e29011ee2ab909b988b187378989eaa19f73734b3a64ece5041520af9a9e9de801bb1802001b22d56387c SHA512 a3c532e26054f793ac71756ebf69c0f17bf60e4510297abffadf02c17188ae74ea374b534bfd9db8cd179c53287734b797142e7e08536a9e3199e269cb014c28
DIST botocore-1.20.96.tar.gz 7842597 BLAKE2B 1a30d4d29c1200f51284a30ee1f512debfbf5542836e32e4971b593a041c4e0793e609b11528a1ecf080e2a01dd4b0ab06bfc44905beee202c23fca983238111 SHA512 9a4973b7484fa5586473dbedd402d6b8adfca18a17373752078f35fc24fda7477a37e2c9fee4779e52c3a60b352ab02943ebf49eb77dd607b79e88d25ae9b6c3
+DIST botocore-1.20.97.tar.gz 7846552 BLAKE2B da0355cc229ba8a0632f67866bf06b27d7b257184b53670e5dc183c6b5a1f4d3a34145de0a3f04abd2adc08de3f0775e3c7e0dbecae729acb5bc05c7ce9acaf2 SHA512 7411d5de8ecf0c42c0142ded036189dcf378cd16f761071beb5bc2a2c240eabb0c4a8c669ce89a5b4e798a0aae92f0e67755627c2a84df77fc2e9557265a4e3b
diff --git a/dev-python/botocore/botocore-1.20.97.ebuild b/dev-python/botocore/botocore-1.20.97.ebuild
new file mode 100644
index 000000000000..762144aabf71
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.97.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}