summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-31 09:52:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-31 09:54:04 +0100
commit0a99b84379a2e0ac6d859ffdd009d84565837bcc (patch)
treea02bd9ae6920d00dfe27b2ea7dbc9314fa24f8af /dev-python
parentnet-analyzer/tcpdump: bump to 4.99.0 (diff)
downloadgentoo-0a99b84379a2e0ac6d859ffdd009d84565837bcc.tar.gz
gentoo-0a99b84379a2e0ac6d859ffdd009d84565837bcc.tar.bz2
gentoo-0a99b84379a2e0ac6d859ffdd009d84565837bcc.zip
dev-python/typed-ast: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/typed-ast/Manifest1
-rw-r--r--dev-python/typed-ast/typed-ast-1.4.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/typed-ast/Manifest b/dev-python/typed-ast/Manifest
index a77958857835..903624a6b663 100644
--- a/dev-python/typed-ast/Manifest
+++ b/dev-python/typed-ast/Manifest
@@ -1 +1,2 @@
DIST typed_ast-1.4.1.tar.gz 208587 BLAKE2B db874caf459cb73345305051a7c4e97244e92b28e94e82f59b38bb91b7c6c69a2531a81c84d483eca8d641bc947f6aa1b98ba59cd880f7560fbdec55bce41787 SHA512 a3154fe723aeadf998694aba0faf516e5b9abb876e4c7d91843b3694474ff6911b3e77a6cb7366cfa8e5a573b331906b6a0b134b25627aaba0dcbe92c4e25590
+DIST typed_ast-1.4.2.tar.gz 208583 BLAKE2B fb94967409c073b3390a133232259605aab0ee893fe53deb0e97a07c814b1c2021815beab4fa680653f75a44b53eb3f02d7c9e330cf51195c2dd668762c9e0be SHA512 9a46f2a4c48bd267445a773463771824be958dfdd1a2df21356d0a763ee2029b51d5b0fddeb16df202f89ba86019640ab45ba520fdad5c550250fe2a135605fe
diff --git a/dev-python/typed-ast/typed-ast-1.4.2.ebuild b/dev-python/typed-ast/typed-ast-1.4.2.ebuild
new file mode 100644
index 000000000000..0a929c8708f3
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.4.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/ https://github.com/python/typed_ast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
+
+distutils_enable_tests pytest