summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:35:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 11:02:15 +0100
commit0c11f0846ab6bd82b4dcf3051b49d84f59864714 (patch)
treeb1068217f2aa6d1a1ceacd1a4369e36fe8b88d4e /dev-python
parentdev-util/libabigail: add missing dep for pkg.m4 (diff)
downloadgentoo-0c11f0846ab6bd82b4dcf3051b49d84f59864714.tar.gz
gentoo-0c11f0846ab6bd82b4dcf3051b49d84f59864714.tar.bz2
gentoo-0c11f0846ab6bd82b4dcf3051b49d84f59864714.zip
dev-python/terminaltables: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/terminaltables/terminaltables-3.1.10-r1.ebuild40
-rw-r--r--dev-python/terminaltables/terminaltables-9999.ebuild12
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/terminaltables/terminaltables-3.1.10-r1.ebuild b/dev-python/terminaltables/terminaltables-3.1.10-r1.ebuild
new file mode 100644
index 000000000000..76c1156f4c7a
--- /dev/null
+++ b/dev-python/terminaltables/terminaltables-3.1.10-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generate simple tables in terminals from a nested list of strings"
+HOMEPAGE="https://robpol86.github.io/terminaltables/"
+SRC_URI="
+ https://github.com/matthewdeanmartin/terminaltables/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/terminaltables-3.1.0-stdout.patch
+)
+
+src_prepare() {
+ sed -e '/requires/s:poetry:&-core:' \
+ -e '/backend/s:poetry:&.core:' \
+ -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/terminaltables/terminaltables-9999.ebuild b/dev-python/terminaltables/terminaltables-9999.ebuild
index ed12c5a82704..c5cb790fdd38 100644
--- a/dev-python/terminaltables/terminaltables-9999.ebuild
+++ b/dev-python/terminaltables/terminaltables-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 git-r3
@@ -24,3 +24,11 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/requires/s:poetry:&-core:' \
+ -e '/backend/s:poetry:&.core:' \
+ -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}