summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-08 08:29:22 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-08 10:47:04 +0200
commit0c2e45fa0264c218875a657a0bad82895424d0f6 (patch)
treec8037aba771bcf4893d30a34d1e993bc1f457c21 /dev-python
parentapp-i18n/ibus-table: drop old (diff)
downloadgentoo-0c2e45fa0264c218875a657a0bad82895424d0f6.tar.gz
gentoo-0c2e45fa0264c218875a657a0bad82895424d0f6.tar.bz2
gentoo-0c2e45fa0264c218875a657a0bad82895424d0f6.zip
dev-python/aesara: Bump to 2.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.6.5.ebuild91
-rw-r--r--dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch46
3 files changed, 138 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 349d20be4ae7..5e72e3f4634c 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,3 +1,4 @@
DIST aesara-rel-2.5.3.tar.gz 8191431 BLAKE2B 698bc3b6f7e84288be3318796989d13d7de92f72c66abfa83b14c08f6310f974f7381d729e712c2bd5e76f398d74a3c5dc03d7515a22254261312e586e3fd461 SHA512 5c1ad9d6ad1fb58be1477713d863f2b1371544ea8293d8e9e1a690860a0483b83c9558827856a2546498bab26360f141a5ee97d4c7f3f2aad773e84f9766a59b
DIST aesara-rel-2.6.3.tar.gz 7845423 BLAKE2B 66b84a10337efc01e37d82793da56b61b1825829d982e24e0f93ebb67cd3c22e5bb2e37c71ab8bd9648b039efaf4c667dc53df2a9613ba9370c2138eb74ca400 SHA512 e0a804c0c3c1cd24753a237c386df9600d2b01cf4991aeca3d794df4068f584a9ab5341b72fa5695ccb9d06f1e4954f450436e3a7ebe4c2efc1354a5c2e5979d
DIST aesara-rel-2.6.4.tar.gz 7845688 BLAKE2B bfd0222c2a8d8e22abb56b785b73a121032832417562046445b8e0b2f6461326ba760d1839fd1acac2215a1547ed48d613998cb4915a07521f4d976a32a811b9 SHA512 a9f47bb4718fab974a35d7eab1b2a5ab8ea7d911dd9d92a791763a659f96b52b9832532e5e13aad10ac8e2f0927d2cc3e97c09e84046fee125925b3ac2898893
+DIST aesara-rel-2.6.5.tar.gz 7849097 BLAKE2B 85bc1579cd22ccc35f727ede3b337d1bdb613924f7568ac403ca1d2da42e442006afdd80e8eaeed14e0c2bd7a550127b9474b9424ffe800426203e1e31e65256 SHA512 cb5ff0f8c5a475ab733000df9d96ea3410c5760f263bb8a8f1de093f47fca3d7428d37253ae114d61d925777e98ab0c8f698f7864615ea32fe20efe6fc5042a4
diff --git a/dev-python/aesara/aesara-2.6.5.ebuild b/dev-python/aesara/aesara-2.6.5.ebuild
new file mode 100644
index 000000000000..5010ebf96928
--- /dev/null
+++ b/dev-python/aesara/aesara-2.6.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="
+ https://github.com/aesara-devs/aesara/
+ https://pypi.org/project/aesara/
+"
+SRC_URI="
+ https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/minikanren[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
+)
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+ )
+ local EPYTEST_IGNORE=(
+ # we do not package numba
+ tests/link/test_numba.py
+ tests/link/test_numba_performance.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x AESARA_FLAGS="cxx=${CXX}"
+ AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
+ AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
+
+ epytest -p xdist.plugin -n "$(makeopts_jobs)"
+ # clean up the compiledir, as it can grow pretty large
+ rm -r "${HOME}"/.aesara || die
+}
+
+python_compile() {
+ esetup.py build_py
+ distutils-r1_python_compile
+ rm "${BUILD_DIR}/install$(python_get_sitedir)/bin/__init__.py" || die
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}
diff --git a/dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch b/dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch
new file mode 100644
index 000000000000..aa36fc26fb12
--- /dev/null
+++ b/dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch
@@ -0,0 +1,46 @@
+From 6e49c314cd5050763f983759d156f26ffbc59368 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 7 May 2022 23:38:31 +0200
+Subject: [PATCH] Allow referencing thread identifier in `compiledir_format`
+
+Add a new `thread_id` key that permits referencing the current thread ID
+(`threading.get_ident()`) in `compiledir_format`. This makes it
+possible to use per-thread compiledirs in multithreaded programs,
+and therefore make it possible for aesara to run multiple compiler
+instances in parallel.
+
+Combined with pytest-xdist, this change makes it possible to run
+aesara's tests in parallel and better utilize multiprocessor (multicore)
+systems. On my Ryzen 5, this provides around 4x speedup (down from 82
+minutes to 20 minutes per test run). Given that we are running the test
+suite multiple times to test different Python versions, this literally
+saves hours at a time.
+
+Prior to this change, xdist would not be able to fully utilize
+the available resources since the compiledir lock would prevent aesara
+from starting multiple compiler instances in parallel, and therefore
+practically serialize tests on compiler invocations.
+---
+ aesara/configdefaults.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/aesara/configdefaults.py b/aesara/configdefaults.py
+index 8121919958..60eb4f997e 100644
+--- a/aesara/configdefaults.py
++++ b/aesara/configdefaults.py
+@@ -7,6 +7,7 @@
+ import socket
+ import sys
+ import textwrap
++import threading
+
+ import numpy as np
+
+@@ -1345,6 +1346,7 @@ def _get_home_dir():
+ "numpy_version": np.__version__,
+ "gxx_version": "xxx",
+ "hostname": socket.gethostname(),
++ "thread_id": threading.get_ident(),
+ }
+
+